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1. PRO600 
 

1.1. Starting of PRO600 
PRO600 is started from LPS menu, or clicks the start menu of "PRO600forLPS" and starts PRO600. 

 

Click "New" and inputs a project name. 
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A setup for the whole project  is displayed. "Mapping scale", "Contour  interval", etc. are set up. A CELL  library 
and the DGN file should use the specified file. 

 

 

 
“Save project” and PRO600 starts by an “Open Dgn file”. 

 

     
Left display                 Right display 
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1.2. Setting PRO600 
1. Setting Display 

Please click the right button of a mouse on a display. 

   

Select “NVDIA Control Panel” and please set up as follows. 
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Select “Screen resolution” and please set up as follows. 
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2. Setting devices 

Edit > devices 

 
 
Select “TopoMouseUSB” and “Click Properties”. Please set up as follows. 
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Edit > devices 

 
 
Select “TopoMouseUSB” and “Click Button Mapping”. You can check the function of each button.   
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3. Setting work enviroment 

    Before beginning plotting with PRO600,  it  is necessary  to create  the work environment of PRO600.  It  is  the  three 

following points to set up. 

① Creation of a feature list. 

② Determination of combination, such as a feature, a layer, a color, line width, line style 

③ A setup of PRO600 

 

① Creation of a feature list. 

PRO600>Library>OPEN 

 
Click “Create” and input the code number according to the data type of feature. 
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② Determination of combination, such as a feature, a layer, a color, line width, line style 

 
 

Double‐click the code to edit. "Symbol definition" is displayed. It sets up as follows. 
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The display of “Library Manager” and “Library Catalog” changes as follows. 
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③ A setup of PRO600 

PRO600 > Settings 

The data type of the DGN data created is set up. 

 
 

The method of a snap is set up. 
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Turn on “Automatic file backup”. It help you when an abnormal end is carried out.   
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1.3. Feature collection with PRO600 
A function typical about feature collecting is introduced to below. 

PRO600 > Tool > main 

 

 

 
 

1. Collect Lines 

    One  line  is  inputted. The  inputted  line  is  created  for  every  neighborhood  and  turns  into  a  continuous  line  as 
"Complex Chain". 
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2. Collect Line Strings 

A continuation line is inputted. Adjustment of height is possible as an option.   
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3. Collect Arcs 

    An arc is inputted. It specifies by three points. 

   

   
 

4. Collect Curves 

    A line is inputted using a curve. This function is not usually used. 

   

   
 

5. Collect Lines Stream 

    A  line  is  inputted arranging the vertex automatically at the  interval and angle which were specified. This function  is 
used for contour line drawing. 
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6. Collect Stream Curve 
    This function is not usually used. 
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7. Collect Shapes 
    Shape data is acquired. 

   

   

 
8. Collect Squared 
  Squared data is inputted. 

   

   
 
9. Collect Symbols 
    A symbol is arranged. 
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10. Place “Spot Height” 

To place “Spot Height” with text, please set up as follows. 
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1.4. Feature Editing with PRO600 
A function typical about feature editting is introduced to below. 

PRO600 > Tool > Editing 

   

17 
 

   
 

1. Edit Vertex 

    The vertex of a line or a shape is edited. 
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2. Move Feature 

    An element is moved. 
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3. Intersect Elements 

    The vertex is created to the crossing element. 

   

   
 
4. Rotate by Origin 

    An element is rotated. 

   

   

 

5. Square Shape 

    An element is rectified right‐angled. 
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6. Identify Feature Codes 

    The code and feature name is displayed. 
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7. Attach Feature Codes 

    The specified element is changed into another code. 

   

   
 
8. Parallel Edit 

    An element is moved / copied in parallel. 
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9. Parallel Edit Shape 
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10. Thin Element 

    A polygon can be reduced and expanded in parallel. 

   

   
 

11. Contour Annotation 

Annotation of altitude are arranged to a contour line. 

PRO600 > Presentation > contour annotation 
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12. Interpolate Contours Pick 

    Major contour is automatically created from Index contour. 

PRO600 > Tools >    Graphics 
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13. Select Code to Highlight 

    A specific element is highlighted. 

PRO600 > Tools >    Display 
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14. Toggle Node Display 

    A part with a node is displayed. 

   

 

15. Toggle Vertex Display 

    The vertex of an element is displayed. Node is displayed in red. 
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1. Alos 
 

1.1. Alos 
ALOS was  launched 2006 by  JAXA and  is a satellite with an Optical and Radar payload. There are two 

optical  sensors  on  board,  PRISM  and  AVNIR‐2. PRISM  (Panchromatic  Remote‐sensing  Instrument  for 

Stereo Mapping) has 2.5m Panchromatic band and stereo mapping capabilities enabling the derivation of 

DEMs, ortho images and as a Pan‐Sharpening tool for AVNIR‐2. 

Backward 
Nadir 

Backward 

Nadir 

Forward 
Forward 

Velocity 

Nadir 
 

 

 

1.2. RPC（Rational Polynomial Coefficient）file 
Rational Polynomial Coefficient (RCP) file contains a conversion equation that relates image coordinates 

calculated  from  a  sensor model  and  ground  coordinates.  RPC  can  provide  the  coordinate  information 

about a satellite imagery without Ground Control Point (GCP). 
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2. Import Alos images to LPS 
 

2.1. Import Alos images to LPS 

1. Create Block file 

1) File > New 

2) Select “Rational Functions” 

3) In this case, select “IKONOS” and click “OK”. 

 

4) Click “Import” and select .blk file. 
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5) Check parameters, and click “OK”. 

6) Select > Edit > Add Frame. 

 
7) Select all images and click “OK”. 
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8) Select Edit > Frame Editor. 

 

9) Click      and select .rpc files. 

 
10) Click “OK”. 

 

11) Click “NEXT”.    And repeat this process. 
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 Aerial Triangulation 3.
 

1. Create Block file 

1) File > New 

2) Select “Rational Functions” 

3) Select “ALOS RPC” and click “OK”. 

 

4) Set “Reference Coordinate System ” and “Vertical” as bellow. 
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5) Select Edit > ADD Frame 

6) “Files of type” : ALOS PRISM JAXA CEOS (VOLALPSM*) 

ALPSM…” and click “OK” 7) Select “VOL‐

 

8) Select Edit > Frame Editor 

PRC file is loaded automatically, input Mean value (in this case “0”). 

 
9) Click “ Next” and repeat this process. 
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2. Orie

1) Select Edit > Point Measurement 

ntation 

 
2) Select    “Classic” and click “OK” 
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 Of cause it is possible to import GCP data as text file. 

3) Click 

Here, we get GCP data from exist map.

“ ” icon and select “Image Layer”. 
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“ ”4) Click   icon and dem data. 
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5) Select “Use Viewer As Reference”. 

 
 

 
 

6) Click icons as bellow. 
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7) lick “Add” button. 

8) Click 

C

“ ” icon. 

9) Select GCP1 on left image. 

10) Click “ ” icon. 

11) Select GCP1 on right image. 

12) Click “Add” button. 

13) Click “ ” icon. 

14) Select GCP2 on left image. 

15) Click “ ” icon. 

16) Select GCP2 on right image. 

Repeat this process as many time as the number of GCPs. 

 
17) Select left image. 

 
Repeat this process as many time as the number of images. 
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3. Automatic Tie Point Generation 

1) Click “ ” icon 

2) Select “General” tab. 

 
3) Select “Strategy” tab. 

 
4) Select “Distribution” tab. 
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5) Click “Run”. 

 

 
6) Click “Close”. 

7) Change “Type ” and “Usge”. 
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4. nt Generation 

8) Click 

Automatic Tie Poi

“ ” icon 

9) Select “General” tab. 

 
10) Select “Point” tab. 
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11) Select “Point” tab. 

 
12) Click “Run” 

13) Click “Report” and check the result. 
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1. MicroStation Basic Operation 
 

1.1. Start and Quit 
1. Start : Begin with the existing files “.dgn” or Files > open. 

2. Shut down :    Files > exit   

 
1.2. Mouse managing 
1. left click : data button (D) accept, input selection 

2. right click : restart button (R)reject, restart 

3. click both buttons at the same time：tentative bottom (T) tentative coordinate selection 

 
1.3. File setting 
1. Create “New” dgn files 

1) File > new 

2) Select “seedfile”   

There are 2 dimensional and 3 dimensional ” .dgn” files ,the dimensions are determined according to the used 

file. 

2. “working unit”   

  “ working unit ” is defined according to each project (Setting > design file > working unit)   

  
3. save settings 

  file > save > save settings   
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1.4. Import and Export 
1. file > export/import 

2. Utilities > Batch converter 
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1.5. View control 

 
 
1.6. Element Attributes (Element Information) 
1. Element > information 

 
 
1.7. Snap 

 
 
1.8. Element type 
1. Line 

2. LineStrings 

3. Text 

4. cell 

5. Circle 

6. Arc 

7. Shape 

8. Complex‐shape      …and so on 
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1.9. Precise input 
1. Accu Draw 

2. Key in : “xy= ” “dx= ” “az= ” …and so on 
 
1.10. Key-ins 
1. View manipulation 

OF= Turn off levels by number 

ON= Turn on levels by number 

 

2. Set element attributes 

LV= Active level 

CO= Active color 

LC= Active line style 

WT= Active line weight 

 

3. Precision input 

XY= <x,y,z> from origin along design files axes 

DI= <distance, direction> from last data or tentative point relative to view axes 

DL= <Dx, Dy, Dz> from last data or tentative point in design coordinates 

DX= <Dx, Dy, Dz> from last data or tentative point in view coordinates 

AX= Distance from Auxiliary Coordinate System (ACS) origin 

AD= Distance from last data or tentative point in ACS coordinates 

 

4. File management 

RD= Open design file 

XD= Open design file with active design’s view configuration 

RC= Attach cell library 

RF= Attach reference file 

DR= Displays contents of a text file 

 

5. 3D modeling 

DP= Set the display depth from 0.0 of view’s z‐axis 

DD= Distance to move display depth from current values 

AZ= Set the active depth from 0.0 of the view’s z‐axis 

DZ= Distance to move active depth from current value 
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1.11. Editing commands  
1. Modify 

 

2. Manipulate 

 
3. Change attribute 

 

4. Fence      …and so on 

 

1.12. Reference files 
1. file > references 
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1.13. Raster Control 
1. file > Raster Manager 

 
 

.14. Select elements by attribute 1
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1.15. “Cell” location 
1. Element > cells 

 
 
1.16. Layer and Layer manipulation 
 
1. Setting > levels > Display 

 

8 
 



Kokusai Kogyo Co., Ltd. 

 

2. Setting > levels > manager 
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2. “Cell” and “Custom line” 
 

2.1. Cell 
In  “MicroStation” positioning elements  called  “Cell”  represents  cartographic  symbols. The  ”Cells”  are  stored  in  the 

library called “Cell Library”, which  is different  to  the design  files. Here we explain  the method  to elaborate such cell 

library. 

4. Symbol form definition 

5. Create “Cell Library ” 

1) To form a new “Cell Library” select “Element”>”Cells”, “File”>”New” and  Origin

2) Input the name of the “Cell Library” on the display dialogue. 

6. Symbol plotting in “design files” 

7. Register the plotted symbols at the cell library. 

1) Frame the symbols 

2) Assure the positioning of the symbol indicating its central point (Click the following icon).   

 

3) Register the symbols at the cell library (Click the “Create” button in the following dialog).   
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2.2. Custom Line 
In “MicroStation” all the elements have the style  line attribute  (“Style”). As own the programming styles registering 

the  continuing  line, dotted  line, etc. Besides  these,  there are  “measured  lines”  to plot  complicated  lines. Numerous 

styles show the measurement availability for omission, which are stored in the file “.rsc”.   

The “.rsc”file is usually located in   

“C:¥Documents and Settings¥All Users¥Application Data 

¥Bentley¥MicroStation V8i (SELECTseries)¥WorkSpace¥System¥Symb”. 

Here we explain the method to create and register “Custom line”. 

 

1. Open the “line Style Editor”. 

1) Element > Linstyles > edit 

2) File > New 

2. Open the “line Style Editor”. 

1) Edit > Create > name   

2) Edit > Create > stroke pattern      Here the space and stripe of the line is adjusted. 

3) Edit > Link   

4) File > save   
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2.3. Merge Cell Libraries 
1. Open the cell library file in MicrostationV8i. 

1) File > models (MicrostationV8i menu) 

2) Click “import models” 

 

3) Select another cell library file. 

4) Select Cell and click “OK”. 

 

5) The new cell was added to the original cell library. 
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1. DTM 
 

1.1. Start ATE 
1. Process > DTM Extraction > Classic ATE or Click “Z” button. 

 
1.2. Setting 
1. OUTPUT FILE : “LPS_TE” for editing DEM data. 

2. OUTPUT form : “Single DTM Mosaic” 

3. Cell Size :   

4. Use Adaptive ATE : on 

 
1.3. Setting in detail 
1. Click “Advanced Properties” 

2. Select “General ” tab 

1) Create Contour Map:   

2) Remove Contours Shower Than:   

3) Create DTM Point Status Output Image : on 

4) Reduce DTM Correlation Area by : 5‐10% 

5) Trim the DTM Border by : 5% 

3. Select “Image Pair ” tab 

It is possible to exclude image. 

4. Select “Area selection ” tab 

Area is set up manually such as a lake, to except. 

5. Select “Accuracy ” tab 

1) Click “Use User Defined Points” 

2) Import GCP data. 

6. Select “Seed Data ” tab 

1) If you have DEM datas for referring, click  “Add External File” and import them. 

 
1.4. Execute 
1. Click “Run” 

 
1.5. Checking the result 
1. After the process, check “ACCURACY INFORMATION”. 
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1.6. Import DEM (if required) 
1. Select Tools > Terrain Prep Tool. 

2. Select Edit > AddDTM 

3. Select Process > merge 
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2. Ortho Mosaic 
 

2.1. Start MosaicPro 
1. Click “Mosaic” icon. 

2. Select “DTM files” and click “OK”. 

3. Select “Compute Active Area” and click “OK”. 

 
2.2. Display Image 
1. Click “Vis” column. 

2. Click    icon and image data is displayed. 

 
2.3. Setting resampling method 

1. Click    icon. 

2. Select “Cubic Convolution” and click “Apply”. 

 
2.4. Create and check Seamline 

1. Click    icon. 

2. Select “Weighted Seamline” and click “OK”. 

3. Select View > Set Maximum Number of Display. 

4. Max Rasters : 2 

 
2.5. Edit the Seamline 

1. Click    icon. 

2. Left click on mouse and edit the seamline. 

 
2.6. Feathering and Smoothing 

1. Click    icon. 

2. Input distance and method. 

3. Click “OK”. 

 

4 
 



Kokusai Kogyo Co., Ltd. 

 
2.7. Correct Images (if required) 

1. Click    icon. 

2. The Color Corrections dialog opens. 

When using two or more of these options, they should be performed in the order they appear in the dialog, from 

top to bottom. 

 
3. Check the box for “Exclude Areas” and click “Set”. The Set Exclude Areas dialog opens. 

1) The overview shows the full extent of the image, and the detail view allows you to zoom in on specific areas to 

create AOIs (Area of Interest) to be excluded from the Color Balancing process. Use the link cursor to isolate 

AOIs. 

2) The first image is displayed in the viewers. Left‐hold your mouse and drag the link cursor to the dark body of 

water in the upper left of the center of the image. In the Detail View, the area is magnified so you can create 

specific AOIs to exclude from the Color Correction process. 

3) Click the Create Polygon AOI icon. 

4) Your  cursor  becomes  a  crosshair when  inside  a  view. Use  the Detail View  to  create  polygons  around  (for 

example) the dark water bodies. 

5) When you have finished, use the link cursor to identify any other areas in the image that need to be excluded 

such as other dark bodies of water, isolated bright urban areas, or bright areas of sun glint. 

6) Create a polygon around each of the areas you wish to exclude from Color Balancing, and click Apply. 

7) Use  the  arrow  keys  or  the  drop  down  box  to  select  the  next  image.  Continue  identifying AOIs  to  exclude 

through all images. Click Apply after excluding areas in each image. Click Close in the Set Exclude Areas dialog 

when finished. 
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4. Check the box for “Use Illumination Equalizing” and click “Set”. Illumination Equalizing dialog opens. 

1) You can change parameters to suit your purpose. 

2) Click Preview to view the  image after applying  Illumination Equalizing. The  image appears  in the right  Image 

Preview section of the dialog. 

3) Click OK to accept the Illumination Equalizing. 

4) Click “OK” in the Set Color Balancing dialog. 

5. Check the box for “Use Image Dodging ” and click “Set”. The Mosaic Image Dodging dialog opens. 

1) Choose Mannual Color Manipulation and click Set. 

2) Look under “Statistics Collection” at “Grid Size” , “Skip Factor X” , “Skip Factor Y” , and “Pyramid Level”. You 

can change these numbers to suit your purpose. 

3) Click Preview to view the image after applying Image Dodging. The image appears in the Dodge Image Preview 

section of the dialog. 

4) Click OK to accept the dodged image. 

5) Click “OK” in the Set Color Balancing dialog. 

6. Check the box for “Use Color Balancing” and click “Set”. The Set Color Balancing Method dialog opens. 

1) Choose Mannual Color Manipulation and click Set. 

2) The first image displays. If the image did not need color balancing, you could skip it, and use the Arrow Keys or 

the dropdown menu in the top left corner to choose another image. 

3) Under Display Setting, make sure RGB is selected. 

4) Choose  the  surface method  you want  to  use  in  order  to  color  balance  the  image.  You may  choose  from 

Parabolic, Conic,  Linear, or Exponential. Unless you are using  Linear as your  surface method, you  can  click 

Common center for all layers in order to use the same center point in each layer of the image. 

5) Click Compute Current and click Preview. The preview viewer displays the color balanced image. 

6) Click Accept after previewing the color balanced image to accept it for mosaicking. 

7) Repeat these steps for all images, and click “Close ” in the Mosaic Color Balancing dialog. 

8) Click “OK” in the Set Color Balancing dialog. 

7. Check the box for “Use Histogram Matching” and click “Set”. The Histogram Matching dialog opens. 

5) Select the Matching Method :   

6) Choose the Histogram Type :   

7) Check if you want to use an external reference :   

8) Click “OK”. 
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2.8. Setting output 

1. Click    icon. 

2. Select the method of area definition. 

3. Input Cell size. 

4. Click “OK”. 

 

2.9. Preview 

1. Click    icon. 

2. Select the area. 

3. Select Process > Preview > Mosaic for Window. 

4. To close the window , select Process > Delete the Preview Mosaic Window. 

 

2.10. MOSAIC 

1. Click    icon. 

2. Select “File ” tab 

1) Input “File name”. :   

3. Select “Output Options ” tab 

1) “Stats Igonore Value” : 0 

4. Click “OK” 

 

2.11. Define the Map Sheets (EARDAS IMAGINE) 
1. Display the Image data on viewer. 

2. Start “Map Series Tool” 

3. Select Edit > Create Custom Maps > From Rectanglar Grid   

4. Click “Set Projection” and input the Datum information and click “OK”. 

5. Input “Map Sheet Extant” :   

6. Click “OK”. 

7. Click    icon. 

8. File > Save As 
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2.12. Output TIFF Image (EARDAS IMAGINE) 
1. Select toolbox > Mosaic > MosaicExpress 

2. Select “Input” tab. 

1) Open the .img file   

3. Select “Output Tiles” tab. 

1) Select “User Defined Tiles” and open .msh file 

4. Select “Output” tab. 

1) “Produce Mosaic Images” : ON 

2) Click “Options” and “Write World File” : ON 

3) Input “Root Name” : 

5. Select “Finish” . 
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The Basic Operation manual of MicroStation 

 
 

Purpose: For understanding about “Digital plotting”, “Digital compilation” and 
“Symbolization”, it is necessary to manipulate the “MicroStation” basically. This document 
mentions elementary operations 

  <Operations>  
1. View Control 
At first; from menu bar/ click Tools/ from pull down/ Tool Boxes. Or Ctrl+T short cut key 

 

 
 
 

Then Tool boxes window will appear, and it is able to select many of tool bar. This time chose 
View Control. At any time it can call any tool bar, when if it need. 
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A 1 2 3 4 5 6 7 8 
 

B 1 2 
 

C 1 2 3 4 5 
 
 

ID Command Contents Action 
Name 

Update View After modification, Update the result Click  “Left”  on  the1 

of modification. window 
A 

Zoom In Increase the magnification of a view. Click  “Left”  on  the2 

window 
Zoom Out Decrease the magnification of a view. Click  “Left”  on  the3 

window 
Window Area Define   the   showing   area   in   the 

window. 
Click “Left” at the 
Upper left of the area 
and Click “Left” at the

4 

Lower right 
Fit View Show all data and fit into the View. No need to Click 5 

Rotate View Change 3D view and defined 
isometric projection view 

No  need  to  Click  or 
drag mouse at

6 

isometric view 
Pan View Move the center of view Click “Left” and move7 

cursor on Clicking left
 Pass “See Help” 8 

 1 View Previous Undo B 
 View Next Redo 2 

 C Passer “See Help” 
Notice:”See Help” means Go to “Help”-> “Tool Index” and Type “View Control” into 
“Index” Tag. 
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 2. Drawing  

 
 
 

D 1 2 3 4 5 6 7 8 9 
 
 

ID Command Contents Action 
Name 

Place Smart 
line 

Draw a line Click  “Left”  on  each  point 
until last point and “Right” 

1 

(start and end point) 
, a line string 
(more then 3 segments) 

D 

Draw a block(Rectangle) Click “Left” at the Upper left 
of the area and Click “Left” at
the Lower right 

Place Block 2 

Draw a shape(Polygon) Click  “Left”  on  each  point 
until   last   point   and   Click
“Close Element” 
Select method or enter 
numeric of diameter, radius 

Place Circle Draw a circle 3 

Hatch Area Place hatch Select method, set hatch4 

appearance in toolbox 
 Attach Tags “See Help” 5 

Place Text Place Text (Annotation, 
Comment, etc) 

Type text into the “Text6 

Editor”  and  Click  “Left”  on 
the point in the Window 

Place active Place  Cell  “  attached  Sell Choose  certain  cell,  click  on7 

Cell library” or its active cell view where might be placed 
Measure Measure the distance 

between 2 points. 
Click  “Left”  on  each  point 
from 1st point and 2nd point, 
then see “Measure Distance” 
window. 

8 

Distance 

 Dimension “See Help” 9 

Element 
Notice:”See Help” means Go to “Help”-> “Tool Index” and Type “Task, navigation in 
dialog box” into “Index” Tag. 
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2-1  About cell making 

i.  For example, draw one element such as polygon or etc. 
 

 
 
 

ii.  Place fence as enclosing the element 
 

 
 

 
 

iii.  Open cell library. 
 Click left Place Active Cell icon 

 

 
 
 

 Click Place Active Cell window’s right button 
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 Cell library window will open 

 
 
 

 Identify the cell 
 

 
 
 
 
 
 
 
 

Return to the Cells tool bar, Click Define Cell Origin, then tentative click in the 
center of element which is defined as cell’s original point. In this time it should be 
defined carefully with snap operation. 
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 Create new cell 

 
 
 
 
 
 
 
 
 
 
 
 
 

After defined center of cell, click Create then Create Cell window will appear. 
 
 

 
For example, Cell name enter “000000” 

 

 
 

 
 

Now, created “00000” cell in Cell Library. The Cell Library can set many cell in order to 
create sell file for users needs or each project requirement. It should be saved in such as 
project folder. Click File from cell Library menu bar/ then new/ enter name and set directory 
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3. Modifying 

 
 
 
 
 

E 1 2 3 4 5 6 7 8 
 
 
 

ID Command Contents Action 
Name 

Element Select elements (one by one). Click  “Left”  on  an  objective1 

Selection Element (Use “Ctrl” for
Plural). 

E 

Fence Define area for Selection and Click “Left” at the Upper left 
of the area and Click “Left” at

2 

Process. 
the Lower right 
 Manipulate “See Chapter3.2” 3 

 View Control “See Chapter 1” 4 

 Change “See Chapter3.2” 5 

Attribute 
 Groups “See Help” 6 

 Modify “See Chapter3.3” 7 

Delete Delete Element (one by one). Click  “Left”  on  a  objective8 

Element Element 
Notice:”See Help” means Go to “Help”-> “Tool Index” and Type “main” into “Index” Tag. 

 
 

3.1 Select (Element and Fence) 
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3.2 Copy and Move 

 
 
 
 
 
 

Copy Move 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

3.3 Another way of Copy (duplicate element) 
i. Select element by using Manuplate from Main tool bar 

 

 
 

ii. Then dragging into Key-in window 
 

 
 

 
 

iii. After dragging enter dl=0 then press Enter 
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iv. Cleck right button (resolve), for exsample select element, then dragging it can define a 

dupilicated element. 

 

 
 

 
v. This duplication method can efficiently use when copy from attached referece file by 

using enclosed fence. 
 

 
vi. Incase of copy whole attached referece file from reference window, it would be better 

to use « merge into master » command. 
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3.4 Attribute 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

Checked attrubute will change. 
 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

3.5 Modify (Extend, Trim, Delete etc) 
 
 
 
 
 

Mod 1 2 3 4 5 6 7 8 9  
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ID Command Name Contents Action 

1 Modify 
Element 

Change the size of Element. 
Move a segment of Element. 

Click “Left” on an element and move. 

2 Partial Delete Delete a section of an element. Click “Left” at the start point and Click

“Left” at the last point. 

3 Break Element Segment   an   element   into
several parts. 

Click “Left” at the point should be 
divided. 

4 Extend line Extend  a  line  to  optional

point. 

Click “Left” on an element and Click

“Left” at the point to be extended. 

5 Extend element 
to intersection 

Extend two lines to the cross
point. 

Click “Left” on an element and Click
“Left” on another. 

6 Extend element 

to intersection 
Extend  a  line  to  the  cross

point. 

Click  “Left”  on  an  element  to  be

extended and Click “Left” on the other.

7 Trim elements Delete element overshoot 
(One by One) 

Click “Left” on the border element and
then Click “Left” on overshoot part. 

8 Intelli Trim Delete element overshoot 

(using line) 

Click “Left” on the border element and

then Draw line on overshoot part. 

9 Insert Vertex Add   new   vertex   into   an
element 

Click “Left” at the point to be inserted 

Mod 

 Delete Vertex Delete vertex Click “Left” at the vertex to be deleted 
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4. Layer and Layer manipulation 

 
 
 
 
 
 

Level Manager Element Informtion 
 
 

Level Display 
 

4.1 Level Manager 
 
 
 
 
 
 
 
 
 
 

Right Click 
 

 
 
 
 
 
 

4.2 Level Display 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

Choose  Layer  for 
show ON/OFF 
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4.3 Element Information (Element Attributes) 

 Element / information 
 

 
 
 

 Element type (generally used) 
 

 1.  Line 

 2.  Line Strings 

 3.  Text 

 4.  Cell 

 5.  Circle 

 6.  Arc 

 7.  Shape 

8.  Complex‐shape  …and so on

 
4.4 Select elements by attribute 

 
It can multiply elect element by element attributes which are by layer, elements types, color, or 
so on. 
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4.5 Level Filter 

 
 

It can save level settings as named layer states. It can restore setting from other setting or 
temporarily setting or setting which is based on efficient working. 

 

 
 
 
 
 
 

Right click on the layer display window/ select Level Manager. Level Manager will appear. 
 
 

 
 
 

Click Filters/ then right click on filter/ select new/ 
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Enter new filter name example “new filter 00” 
 
 

 
 
 
 
 
 

Right click on new filter/ then select level group 
 
 

 
 
 

Select setting layer which are as on purpose of purpose 
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Select Filters from Level pull down menu 
 
 

 
 
 
 
 
 

Select Filters in list of name, for example new filter 00. Then main window will be restored as 
selected levels at once. 
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When return to original level setting, turn on all level in the level display or beforehand set filter 
as all level “on” 

 
 

 
 
 

Turn on all layers on Level Display 
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 5. Raster Control 
 

Open Raster Control tool  
Raster Manager Tools->Raster->main 

 
 

5.1 <Insert an Image> 
Open Raster manager ->File ->Attach 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

In case the Image has a coordinate: check off 
 

 
 

5.2 <Other method of insert an Image> 
 
 

Drag and drop target image into Raster Manager 
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In case of the image has georeference, Check box might be out both. 

 
 
 

5.3 <Detach the Image> 
File ->Detach or right click the detachable image in raster manager/ from pull down 
menu detach 

 
 
 

5.4 <Batch image convert> File ->Detach 
File ->batch convert 

 

 
 

Raster Manager can be converted image format with batch processing, these format 
which are in generally used. 
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From batch convert, “Raster convert” window will paper. 

 Click “Add... “button, it is selected the several image file from target directory 

 
 
 

 Select convert format from the pull down menu 

 
 
 

 Click option, it can select raster georeference file and its name, description.. 
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 Select directory for converted images 
 Then click “Convert” 

 

 
 

 It may takes a while time why depend on image volume. 
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6. Save setting, Compress 

 
 

6.1 Save setting; on the starting working, the DGN working file must be set at least following 
then “Save setting” 

 
 

i. Form menu bar / Settings /pull down menu Design File 
 

 
 
 

ii. Design file Settings window will appear, it can set basic DGN file settings which are 
able to be available for fitting each DGN file; however it can set many categories. 
Minimally, it should be set Snaps, Working Units, and grids if it needs. 

 
 

 Snaps; “Mode” might be “Key point”, “Divisor” value 1. 

 
 If it needs temporarily to change another mode in during operation, it can 

change snap mode from “Snap Mode tool” box. 
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 Working Unit; Format might be “MU”, Mater Unit is Meters, Sub Unit is 

Millimeters, Accuracy is 0.1234 or more, it is depending on the specification. 
 

 
 
 
 
 

iii. After setting the DGN file, it can be saved DGN file on disk and these DGN file 
setting shall be save the setting. From menu bar File/ from pull down/ Save Setting. 

 
 When changed desk top appearance such as toolboxes its arrangements can save 

setting. Before close the working DGN file, it should be saved setting; it would be 
made better to become a habit such as Save setting 
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7. Compress; reduces the file size of working DGN, it must be clear the UNDO data, if it 

needs other unused recourses it might be select the delectable recourse from option setting. 
 

 
 File/ Compress/ pull down Design 

 

 
 

 File/ Compress/ pull down Option 
 

 
 

 Check “√” in left box, the Action will be done same at the “Compress” 
Usually it unnecessary to select these actions, it might be needed at the time of 
all completion working. 

 After changing options might be done “save setting” again, then compress 
design. 
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8. Save, Export 

 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

 It can save as other CAD format such as DWG, DNG(v7) . in case of save as DWG 
format it might be needed to change “option” setting and “save setting” from menu 
bar. 

 
 File/ Save as DWG, DXF/ click Option, “save as DWG/DXF Option window 

will appear, then click “Entity Mapping” and then change the value as 
following. 
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 then click next “Filled element” 

 

 
 
 

 then click next “2D unfilled Elements 
 

 
 
 

 then click next “3D unfilled Elements 

 
 
 

9. Mouse Control 
 
 
  Cancel  

Accept 
 
 
 
 
 
 

Revolve: 
Zoom In/Out 
Keep Pushing: 

Pan 
 

 
 
 
 
 

 Mouse managing 
 left click : data button (D) accept, input selection 

 right click : restart button (R)reject, restart 

 click both buttons at the same time：tentative bottom (T) tentative coordinate 

selection 
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Instruction for editing of data 
 
 

1. Objective 
 

The objective of editing data is creating point, line, and polygon data for Cartography. As 

for creating polygons, ”Data cleaning” (Delete short elements, Delete Duplications, Fix 

Gaps and Dangles) and ”Create Topology” are required. 
 
 

2. Work flow 
The flow in this work is following. 

 
 

Sorting layers (Use/No use) 
 
 
 
 

Data Clean Up 
 
 
 
 

Create Topology 
 
 
 
 

Create Polygon 
 
 
 

 Sorting layers; the unused layer for polygon should be distinguished by using cad 

function freeze, display off, setting into other new layer or save to other file such as 

temporary data which should be merged after polygon creation. 
 
 

3. Type of Data 
3-1 Type of data 

 

There are 4 types of elements in the topographic data as follow. 
 

Type of data Explanation Examples in this project 
1 Point No length No 

width 

Cell(symbol) 

GCP point, regular buildings, regular 

prominent features which are hospital, 

factory, school, port, mine, bridge, water 

source, reservoir, well 

 

Symbol 

etc. 

2 Poly line With length road, railroad, single line river, contour, etc. 
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     No width 

3 Polygon With length dwelling area, sea,double line river, 

vegetation, 
 

With width 

etc. 

4 Text Characters administrative name, prominent features its 
 

explanation, etc. 

3-2 The theory of polygon creation by using ”Point” and ”Smrat line or Polyline ” 
 

Regular symbol (Cell or Block) 
 

Unused for polygon topology 
 

Point (symbol) 
 

Cell or Block 
 
 
 

Line 
 
 
 
 
 

Line (Smrat line or Polyline) 
 
 

Point 
 
 
 
 
 

after poygon creation, the poygon area can fiil 

in color or hatching such as representation. 
 
 
 
 
 

On the polygon creation, text, point 
(symbol),cell (symbol) are able to deal as a 
centroid of cirtain boundary. 

 
 

One cirtain polygon must has a centroid 
its inside is basic rule of polygon 
topology. 
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3-3 About each data type 
 

To know the classification of data type, See “SYMBOLES DE LA CARTE 

TOPOGRAPHIQUE DU TOGO (ECHELLE 1:50000)”. 

 When referencing the specification, it shall be use the latest version. 
 
 
 
 

4. Data Cleaning 

4-1 “Data cleaning” Tool usage 
 

Open “BENTLAY MAP” then select “Geospatial “from pull down, and then “Topology 
 

Cleanup” 
 

 
 
 
 

In the tool bar 
 
 
 

⑨ 
① 

 

 
 

② 
③ ④ ⑤ ⑥ ⑦ ⑧ 

 
① Find duplicate linear elements 
② Find similar linear elements 

 Automatically removing similar liner element might make gaps, dangles line. 
③ Find line network fragments 

 When tolerance value setting is large number, the result must be increased. 
④ Thin linear elements: remove thin object less than tolerance---remove 

vertex---filtering? 

⑤ Segment linear elements: Segmentation---Break 
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 Usually setting mode should be “Element”. 
⑥ Find gaps 

 When the mode selected “All repair “under large numeric tolerance value setting 

is large number, the result might be created unexceptional elements. 

⑦ Find dangles 
⑧ Connect line work 

 Use for non-elevation line features only, when the contour line connected it must 

be lose its elevation value. 

 When connecting liner elements shall be done layer by layer, if 2 or more layers 

connected at once the result must be created failure element. 

⑨ Find slivers 
 The Sliver polygons error can detect in polygon topology creation procedure 

also. 
 
 

4-1 The Workflow of “Data Cleaning” 
 
 

Use Tool① Delete duplicating elements 
 
 
 
 

Create nodes on the intersection of lines Use Tool⑤ 
 

 
 
 

Use Tool② Edit and Delete gaps 
 

  Use Tool③ 
(Edit gaps, Connect gaps, Delete short elements courts) 

Use Tool⑥ 
 
 
 

Connect liner elements Use Tool⑧ 
 
 
 

Use Tool⑦ Edit dangles 
  
  
  

 
Use Tool⑤ Create nodes on the intersection of lines 

 
 

Notice: The elements should be enclosed by Fence before the Tool running. 
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Some of the data cleaning function should be set tolerance value more than “0” in order to 

exactly find error of elements however if it was set large value the result might be detected 

normal elements as error. 
 
 

The tolerance value should be selected by depending map scale. In case of large scale map 

the tolerance value can be small number, the other hand small scale maps the number must 

be increased. Furthermore decision of the number should be taken consider in line data 

condition which is interval and angle of vertex. 
 
 

4-2 Sample tolerance value of small scale map as 1/50 000 
 

 These actions are directly edited element. In accordance with the situation, it is 

necessary to save backup data before “Data cleaning”. 

 These Tolerance are as one kind of sample, actually true value cannot fix so far. 
 

It must be required to alternate the value by satiation of elements, map scale, its 

specification and so on. 

① Find duplicate linear elements 
It can no more be detected than a just overlapped element. 

② Find similar linear elements 

Approximately between 0.1mm to 1mm on the map; as 5m to 50m on the ground, it is 

including “0” also. The value “0” can no more detect than a just overlapped element. 

As for percent value is 0.1% up to or more, however the value increasing might be 

decrease error. 

③ Find line network fragments 
Approximately between 0.01mm to 1mm on the map; as 0.5m to 50m on the ground, 

it is including “0” also. The value “0” cannot find any error however the large value 

setting might be increased error of normal element. As for this value should be 

depended vertex interval of stereo plotting line condition. 

④ Thin linear elements 
Normally it is not applicable, when the liner elements has inappropriate situation such 

as zigzag like with too much vertex, poor digitized or vectorlization line. 

⑤ Segment linear elements 
Generally the value should be “0”, mode is “elements” 

⑥ Find gaps 

The tolerance value should not be “0”, approximately between 0.01mm to 1mm on 

the map; as 0.5m to 50m on the ground, it is including “0” also. The value “0” cannot 

find any error however the large value setting might be increased error of normal 
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element. As for this value should be depended vertex interval of stereo plotting line 

condition. 

 
⑦ Find dangles 

The tolerance value should not be “0”, approximately between 0.01mm to 10mm on 

the map; as 0.5m to 500m on the ground. In case of value “0” cannot find any error 

however the large value setting might be increased error of normal element. As for 

this value should be depended vertex interval of stereo plotting line condition. 

 
⑧ Connect continuous line work 

No apply value 
 
 

⑨ Find slivers 

The value which is ratio of length to width might be depending on liner elements 

situation. It is necessary to closely examine however it might be able to be 
detected by other function. 

 
 

Notice: when used tolerance value, it shall be checked and edited with eye observation. 
 

If the elements are applied to auto repair, delete, merge it will be brought to failure 

results. 
 
 

4-3 Order of Topology clean up actions 
 

 The order of cleanup actions can produce different results. Specify the order 

by moving cleanup actions up or down in the list. The action at the top of the 

list is performed first. 

 Errors should be fixed before a topology creation. The following table indicates 

data errors that should be considered when you are creating a network or 

polygon topology. 

 Point topologies do not usually require cleanup. 
 
 

Error Network Topology Polygon Topology 

duplicate linear elements Must remove Must remove 

line network fragments Check for validity (over, 

under pass) 

Can remove 

Can remove 
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Segment linear elements Must remove Must remove 

Find gaps Must remove Must remove 

Connect line work Can remove Can remove 

Find dangles Check for validity. Can Must remove 
 

remove 

Thin linear elements Can apply Can apply 

Segment linear elements Must remove Must remove 
   

After applied Connect line 

work 

After applied Connect line 

work 

 
 
 
 

<Appendix> 
 

Classification Figure Remarks 
 Duplication There are some lines on 

the same position. 

 Short Elements Use tolerance setting for 

the map scale. 
 

(Include o length) 

  Use t tolerance setting 

for the map scale. 

Gap 

  Use t tolerance setting 

for the map scale. 
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Classification Figure Remarks 
 Dangle Use t tolerance setting 

for the map scale. 
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5. Create Topology 
Open tool boxes “Topology Cleanup” and “Topology Creation”. 

 
 
 
 
 

① ④ 
 
 
 

② ③ 
 
 
 

1.   Create shape elements from boundaries and centroids 
 

2.   Create centroids from other elements 
 

3.   Associate linkages 
 

4.   Validate topology 
 
 

Work flow of “Topology Creation” concept 
 

 
 
 

Show (display) the lines which necessary for “Topology Creation” 
 
 
 
 
 

Validate topology for “Topology Creation” 
 
 
 
 

Create new layers for shape (polygon) 
 
 

Show (display) a layer of target symbols and line elements 
 

Continue on all necessary layers 
 

Create polygons in every layer 
 

(The area that has symbols inside it could be polygons in the active layer) 
 

 
 
 

Notice: The object elements should be enclosed by Fence before the Tool running. 
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I. Show (display) the lines which necessary for “Topology Creation 
 

1. Rotate cell to right angle 
 

Cells which are not required angle such as vegetation, school, hospital, other 
remarkable point symbols etc. should be rotated right angle “90 degree” from 
bottom neat line. 

 Action: Select cells by using attribute selection then change their attribute of angle 
to “0” degree in “Elements information window. 

 House symbols and the cell need rotation shall not be rotated right angle. 
 

 
 

 
 

Fig 1 rotated cells 
 
 

 
Fig 2 after rotation 

 
 

2. Turn off the unnecessary layer for “Topology Creation” 
 

Cells and any elements such as school, hospital, and other remarkable point 
symbols etc., line elements which are unnecessary for shape (polygon) 
creation must be turned off its layer. 

 Action: display off in “Level Display “window or click on target element by using 
 

“Change level”. 
 

 Other: create “layer filter” for “Topology Creation” before working, it can reset 
display status at once. 
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Fig 3 after display off layer status 
 
 

II. Validate topology for “Topology Creation” 
 

1. Make layer for validations text in “Level Manager” then the layer change to active 
one. 

2. Set appropriate text size for validations such as 25m-50m or any for fit map 
scale. 

3. Check again that shaped elements must be dropped and all elements elevation 
value must be “0” m. 

4. Set fence as enclose the element 
 

5. Click “Validate Topology” icon 
 

 
 

Fig 4 
 

6. Retouch elements according to result of validation error code 
 

Code Meaning 

multA the centroid has multiple associated Areas 

multC the polygon has multiple associated Centroids 

noA the centroid has no associateed Area 

noC the polygon has no associated Centroid 
  “unused” Boundary element (not used to close a 

polygon) 
unuB 

 
 

7. Repeat “5” to “6” up to completion of no detected. 
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Fig 5 non detection of error 
 
 

III.  Create new layers for shape (polygon) and show (display) a layer of target 
symbols and line elements 

1. Create new layers for each shape (polygon) elements such as ****poly, ****f 
whatever then it must be set active layer. 

2. Show only a target centroid layer and all line elements layers. If two or more 
centroid layer is showing the polygons must be created as mixed into a target 
layer. 

3. The theory is one centroid layer must be fit on one polygon layer. 
 

 Action: layer “On, Off”, Create new layer by using “Level manger” 
 

 Place fence, Create shape. 
 
 

IV.  Create polygons in every layer (The area that has symbols inside it could be 
polygons in the active layer) 

 Work “III “is repeated up to completion. 



 

 POLYGON 
MAKING  

 

 
Usage of Bentley 

MapV8i 
 

 

 

 

 
2012/07/30 
 
 



 

 A-Polygon making（using Bentley MapV8i） 

1. Purpose 
From these lines, cells elements to 

Fig 1 

 
 

Fig 2  
To result each polygons creation 

 

 
 

2. How to make polygon – Basic – 

1 
 



i. When making polygon, it is needed geometry which is surrounding line geometry (line) and a cell or a 

point is placed into the enclosed line geometry. This cell or point situation is called Centroid. 

Fig 3 

One certain polygon 

geometry; surrounding 

line elements 

 
 

Fig 4 
ii. Click “Place Active Point” from Base Geometry tool bar  

 

 

Fig 5 
iii. Click the inside of the enclosed line geometry then place a point. 

 

Place point into 

the geometry 

 

 

Fig 6 
iv. Click “Place Fence” from Fence- Main Task tool bar 
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Fig 7 

v. Select “Fence Type to Block” then Select “Fence Mode to Inside “ from “Place Fence” pull down menu 

 

 

 

Fig 8 
vi. Place “Fence” as enclosing line geometry 

 

 

 

 

Fig 9 
vii. Tools from menu bar>Geo Spatial>Topology Creation then select “Topology Creation” 
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Fig 10 
viii. “Topology Creation” will open  

 

 

Fig 11 
ix. Click ”Create Shapes”  

 

 

 

 

 

Fig 12 
x. Then Click in working window (Accept) 
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Fig 13 
 When it has created polygon, it will be shown as “Created 1 shapes” in bottom message window. 

The polygon is called “shape” in the Microstation. The Shape (polygon) is coincident original line geometry, 

although it is apparently invisible element. Actually it selects the shape and slightly moves anywhere. Certainly 

you can see the created shape (polygon) 
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Fig 14 Original  

Shape (polygon) 

 
3. Challenge a bit complicated one 

 The work flowing 

1. Line features Z value (elevation) change entirely “0”m. 

2. Beak crossing lines 

3. Place “Centroid” in the enclosed line (Area) which will be created polygon 



4. Check and retouch polygon topology in order to create shape. 

5. Polygon creation (shape) 

 

 The elements Z value (elevation) change entirely “0”m. In case of the data has elevation value, it might not 

be able to be completely done topology creation and data cleaning work. As the first, before starting work, the 

elevation attribute of elements are set to “0”m. 

Fig 15 
Let’s open manual001.dgn 

 

 
 

3-1 Active Z setting 
Fig 16 
Enter “AZ=0” in “Key in” window, then “tentative click” in the working window. After that “active Z” setting, the file 

basement elevation will be “0”m. 

 
 In case of checking the “active Z”, “tentative click” in the working window it will be shown the X, Y, Z 

coordination number in bottom message window by “tentative click” in the working window. 

 

Fig 17 
When “tentative click” in the working window, the value 0.000000 is telling file basement changed “0”m. 

 
 

3-2 Chang Z value to “0”m  
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“Place Fence” > Fence Type select “Block “> Fence Mode select “Inside” 

Fig 18  
Place fence as window... in dragging  

 
Fig 19 
After placed fence, select “scale” from Main-Main Task 

 
Fig 20 
Setting the scale value X, Y, Z window, in this case it needs to change Z value, click unlock key mark 

 

 
 

Fig 21 
Change Z Scale value as 0.00000001, and then press return. 

*If it is not entered more than the number of below X, Y decimal point, it cannot set 0.000000 unless it finally puts 

in 1. 
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Fig 22 
Put check mark “Use Fence” checkbox 

 

 

Fig 23 
Click “left button” (accept), wait a bit then Click “right button” (reject) 

 
Fig 24 
“Tentative click” (press both button) at any object, Z value will be shown in the bottom message window 



 
Fig 25 
Check X, Y, Z coordination number; it is a success! Now the value is 0.000000. 

 
 

3-3 Beak crossing lines 
 The line breaks off at the Intersection or the contacting points  

 

Fig 26 
In the same procedure, enclose all element Click “Place Fence” > Fence Type select “Block “ > Fence 

Mode select “Inside” 

 

 
Place fence as window... with dragging’ 
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i. “Tools “ from menu bar> Geo Spatial> Topology Cleanup, select “Segment Linear Element” then click in 

the fence. 

 

ii. After accept the command, selected lines are break between intersection and to other one or contacting 

point. Thus, it is O.K. the lines are beaked. 

 

 
Fig 27  

 

 

 

 

 

iii. Next, the object which is already shape is also dropped into “line string”. 

These shape objects are mostly scale size building or small islands which were drawn with closing during stereo 

plotting. Since it is already shape--it might be OK itself—however if “fig 29” is as, if scale size building has been 

remaining “Shape object” it will be troubled variously.  

Fig 28 
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 Using tentative click on element or 

to bring selector near element, it can see what is element attribute/ 

Above “fig 29” element is “shape” element. 

 

As for ground feature under the lower part in sample data; island in open water area will be created as doughnuts 

polygon. Therefore the shape objects have to be dropped into line object before topology creation. 

 Fig 29 
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 For example, the open water area has “sea” cell (symbol) is the sea, the island has “Gra” cell. 

In this sample data, island area is shape element now, ----- 

i. It needs to create doughnuts polygon like this---- 

 
ii. However it will become like this (the doughnut part is not made) because island is still shape element. 

 

 Before polygon topology creation, the shape elements shall be dropped. 

 

3-4 Drop shape object 
Select only shape elements in working file. 

Tools from menu bar> Edit > Select by Attributes 

Fig 30 
Open “Select By Attributes” 



 

Fig 31 
Select all names of Levels in the left window, Select type of “Shape” in the right window. 

Then click “Execute” after that it will be selected only shape object in this data. 

 Level selection status is not always same; it might be changed by case by case and selection purpose. 

 
 

Fig 32 
Select “Drop Element” from Main-Main Task drop Element 
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Fig 33 
Drop Element will appear 

By a default, there is no check mark despite Line Strings/Shapes. 

A check is put in box. Then clicks in the work window and elements will be dropped 

Above building and island coast line are changed each segmented line. 

 

 
 

Fig 34 
After dropped shape element, tentative click on the dropped element will be shown element attribute which is 

became line elements. 
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3-5 Place Centroid 
Fig 35 
The purpose is finally to create such as following below “Shape “elements. 

One “shape” object must have one “centroid” 

 

 

Fig 36 
From menu bar Settings > Level > Display select Level Display then it will be opened the Level Display widow. Or 

short cut key “clothe”. To be placed point (centroid), double click on “road_point” layer. It will be turned green 

hi-light to “active level”. 
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Fig 37 
Select “Place Active Point” Click it is placed point into any inside of road. 

 
 

Fig 38 
For example, this point is as centroid for road shape (polygon) 

 
 In case of few numbers objects, it can place point one by one. When the file has many of topology elements, 

it can automatically process. In case of these scale size building can use automatic process. 

 

Fig 39 
The building features are drawn in building_line level however point is as centroid should be place into 

building_point level. 

 

 

Fig 40 
Turn off other level then turn on only the building layer. 
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The small building symbols are also accommodating in the same level however they can be left. The centroid to 

be made from now will be created into enclosed line string objects which will be shape element. 

 

 

 

Fig 41 
Enclose all elements by fence without having to worry about. 

 

 

 

Fig 42 
Next select “Create Centroids” 

 

 

Fig 43 
“Create Centroids” dialogue window will open. 

Change “Mode” to Boundary 

Change “Type” to Zero Length Line 
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 *Although Zero length line (the line is exactly coinciding starting point to end point) is called “point” in 

Microstation. 

 

Fig 44 
Click in the working window 

The point (centroid) was made. Upper left symbol buildings (cell) are not made point inside it here. 

 
Fig 45 
The data looks like below. So fur 

 
 

 

4.  Check and retouch polygon topology 
Check and retouch polygon topology work must be required. 

Fig 46 
Create new level which for the check result (mark) will be written. Settings> Level> Manager, then open Level 

Manager. Or right button click on the Level display then select Level Manager from pull down. 
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Fig 47 
Click “New Level”, make new level. 

 
Fig 48 
Change the name New Level(0) to as enter “CK” ( level name might be as you like) 

Then close Level Manager, double click level “CK” on the Level Display it be active level. 

Level Manager might be closed or left. 

 
 

 

Fig 49 
Then, check all elements as one trial. 

Enclose all elements “Place Fence” 

 

18 
 



 
Fig 50 
Select “Validate Topology” from Topology creation, click in the working window. 

 

 
Fig 51 
Select “Validate Topology” from Topology creation, click in the working window. 

 

 

Fig 52 
It might be such like error marks are written in level Ck. 

For example, it is error "multC" made two or more “Centroids” (cell) were in the area which has a triangle here. 
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Fig 53 
This “noC” is…It is showing “noC” that the area has not contained any “centroid”. 

 

 

 

 

There are kinds of error other than the above-sample error. 
*Following below list. 

20 
 



Fig 54 

 
 

 multA: There is nothing not much. 

 multC: it will be many as errors. There is two or more “centroid” in the area. Show sample 

as following 

Fig 55 

*In this case, tow centroid are in the area. 

Fig 56 

The error mark is such like “multC” 

Fig 57 
 n rks line inside feature which the area is incomplete, it will have to enclose for 

the “centroid” 

 

oA: When it ma
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Fig 58 

 noC: When there is not any “centroid” into the area. 

 

 

Fig 59 

 unuB: It comes out to incomplete boundaries line which is not consisted any polygon 

 

 
Fig 60 

 It is such a pattern that it is often. 
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Fig 61 

 Although, the line and centroid also seems to be completed apparently---- 

 

 

Fig 62 
 If the portion of a circle is zoom in…. 

Being such as this….However it will be detected such like error from finished data cleaning data. 

 

 

B-Create Polygon  
1. Then trial, Let’s actually create polygon 
 

1-1 First trial is; Create building polygon from scale size building line. 
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1-2 The level (layer) which for creates shape must be as each map object item 

 

1-3 In order to make shape to the corresponding layer, it is displayed only the layer of a (line), (point), (poly); 

(Here, they are building_line, building_point and building_poly). 

 

1-4 It checks first. “Level CK” turn to active layer. 

 

1-5 Error result will be written into “Level CK” 

 

1-6 In this case, other level are turn off displaying. (Only target layer is displayed.) 

 

Fig 63 

 

 

 

 

 

Fig 64 
 It thinks in the working window as such like view. 1-6 other levels are turned off displaying. (Only the layer 

required for work is displayed.) 
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1-1 Go to check. 
“Place Fence” select “Validate Topology” then click in the working window 

 

Fig 65 
In this case “noA” will be nothing to be featuers becouse of the cell element itself. Delete “noA” directly. As for this 

case “nothing to do any” , “unnecessry to do any”, “not need to retouch” are called as “OK error”. 

 

 
 

Fig 66 
The three building symbol (cell) are detected “noA” as error which as centroid has not its boundaries. After 

“Validate Topology” error marks will be placed at the features and Results window is shown detail of error 

information 
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1-2 Go to create polygon (shape） 
 Change active level to building_poly, the place fence, next as following… 

Select “Create Shapes” from Topology Create tool box, then click in the working window 

 

Fig 67 
When after created polygon, it is shown as “Created 2 shapes” in bottom message window. 

 

 

Fig 68 
Display only building_poly level,  

 
 

Fig 69 
Change elements fill type to opaque 

 

 

Fig 70 
 Try to fill shape in color. Select the shape as enclose with cursor.  

Select from Change Attributes – Main Task > select Change Element to Active Fill Type 
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Fig 71 
By a default, since Fill Type is none, it changes into Opaque. Although Fill Color can also be chosen, it is as 

ByLevel here. 

 

 

Fig 72 
The shape (polygon) is filling color which is by level’s setting then display all. 

 

 
Fig 73 
It is such like so far…. 

 
1-3 Next, create road polygon(shape） 
Fig 74 
If only display road related level when as building polygon making… 
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Fig 75 
It will become like this…It have to be enclose the road by using outside line (neat line) Turn on neat line level 

 

 

Fig 76 
i. Enclose window “Place fence”, select create shape. Filling color same as building polygon creation. 

 

 

 

Fig 77 
Use hatch in the shape  

From “Task”>Drawing>most left side icon in R window in “Tasks”>Hatch area 
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Fig 78 
Hatch setting, in this case  

Spacing 1.5, angle 45 Then click on target element, it will be hatched. 

  

 

 

 

 

 

1-4 Try to create sand polygon (shape） 

Fig 79 
Make level “sand_poly” for sand shape (polygon) 
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Fig 80 
Turn on “sand level”, the sand level has only symbol (cell). 

 

 

i. Turn on other level which are consisting the sand boundary.  

ii. “Place fence”, select create shape same as other’s created 

iii. After making polygon, filling color or non filling if it need. 

 

1-5 Next, try to create grass_polygon (shape） 

 How to make is same, however there are partly with attention. 

In the chapter 4 Check and retouch polygon topology when it was first checking (validate topology). 
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 It needs to draw vegetation line or some feature’s line, if in case. 

 
 If this upper area is as grass vegetation, it needs to check one more thing. 

The grass vegetation will be required doughnut shape which should be extracted scale size building shape before 

creating polygon. 

 

 

1-6 The last is sea_poly 
 Although it is doughnut –like shape, 
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 Turn on “sea level” and neat line level. “Place fence”, select create shape 

 
 Polygon complete .Fill in color  
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