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1. Introduction 

 
The purpose of the Softcopy Exploitation Tool (SOCET SET®) software is to support 
imagebased softcopy applications such as map-making, mission rehearsal, and photo-
interpretation. 
SOCET SET generates databases and products such as Digital Terrain Models (DTM), 
reports, vector databases, orthophotos, image maps, and image mosaics. SOCET SET 
supports a wide variety of applications, including: 

• Populating a GIS database (vector or raster) 
• Producing image maps 
• Civil engineering 
• Mission planning 
• Targeting 
• Mission rehearsal 
• Sensor research and development 

The SOCET SET software consists of over sixty application functions that can be 
chained together to form a processing flow that inputs imagery, performs the requisite 
analysis, and produces the final hardcopy or softcopy products. This User’s Manual 
describes the application functions in detail, including the following: 

• Data import capabilities for imagery, feature, and terrain data 
• Automatic extraction of Digital Terrain Model (DTM) elevation data 
• Interactive graphical editing of DTM data 
• Interactive two and three-dimensional feature data extraction 
• Orthophoto generation 
• Perspective scene generation 
• Point positioning, three-dimensional mensuration, and targeting 
• Image mosaicking 
• Image enhancement 
• Data export functions for softcopy databases (imagery, feature, and terrain 

data), and hardcopy products (image maps) 
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2. Typical Product System Flow 

 
Imagery is input to SOCET SET from either a digital softcopy source, such as SPOT or 
Landsat, or by scanning film-based imagery. The workstation products are in either 
softcopy format (such as DTMs, vector databases, orthophotos, etc.) or hardcopy format 
(such as image maps or photorealistic perspective scenes). 
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3. Using Satellite Imagery 

 
   Overview of SPOT, JERS, and IRS 

SPOT, JERS, and IRS Imports read imagery and geo-referencing information from 
CD-ROM, magnetic tape, and disk media into SOCET SET. SPOT imagery is 
available from SPOT Image Corporation and other distributors. JERS imagery is 
distributed by NASDA. IRS imagery is available from various distributors. 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

When to Use SPOT Image Import 
You use SPOT Import when you have SPOT data and you want to exploit the image in 
the data set. You run SPOT Import after creating a project to hold the imagery. After 
importing a SPOT image, you can the proceed with Triangulation and then data 
extraction. SPOT Import works in projects with the Geographic, UTM, or Grid 
coordinate systems, but not the LSR coordinate system. 

 
Formats Supported 

SPOT imagery is supplied in a variety of formats and processing levels. The various 
formats are described below. 

Categorized by spectral type, SPOT comes in several types: 
• Multispectral without short-wave infrared (SWIR) (known as MLA or Xs) (3 

bands) 
• Multispectral with SWIR (known as Xi or I) (4 bands) 
• Panchromatic (known as PLA, PAN, P, or M) 
 

SOCET SET imports all the above types of SPOT imagery. 
SPOT multispectral imagery comes in two formats: Band Interleaved (BIL) or Band 
Sequential 
(BSQ). SPOT panchromatic imagery always comes in BSQ format. SOCET SET imports 
both 
BIL and BSQ formats. 
Your SPOT imagery may have been preprocessed by your supplier to assist with control 
or geopositioning. 
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There are four processing levels available from SPOT: 
• 1A – Raw. This is unrectified data and the pixels may have non-uniform GSD. 
• 1B – Rectified. The imagery has been resampled and geo-coded to a uniform 

GSD. 
• 2 – Controlled. Controlled support data is provided that is based on GCPs. 
• S – Stereo. A relative orientation has been performed on this SPOT stereo pair. 

SOCET SET accepts processing levels 1A and 1B only. Processing level 1B is the most 
common type of SPOT imagery. 
 
SPOT Image has introduced the DIMAP format. They are distributing all SPOT 5 data in 
this format and will be transitioning data from previous satellites to DIMAP. If you have 
a DIMAP data set, you must import it with SPOT DIMAP Import. SOCET SET supports 
the same SPOT DIMAP products as with previous formats, that is, SPOT full-scene 1A 
and 1B in both panchromatic and multispectral. 
 
Finally, the SPOT tape format varies between SPOT distributors. SOCET SET accepts 
imagery in the standard format of the SPOT Image Corporation and in the standard 
format of the Canada Centre for Remote Sensing (CCRS) and Australian Centre for 
Remote Sensing (ACRES). The image formats processed by SOCET SET are taken from 
The SPOT Scene Standard Digital Product Format (S4-ST-73-01-SI), SPOT Image 
Corporation, 1995, and Standard SPOT MLA/ PLA CCT Format (DMD-TM85-428A), 
Canada Centre for Remote Sensing, 1985. SOCET SET supports the “CAP” data format. 
 
Some CCRS SPOT data sets have a defect which causes the image to be shifted to the 
east or west. You can set a special environment variable when starting SOCET SET to 
fix the problem. There are two ways to set the variable. One is to add -setenv_no_arg 
CCRS_ROLL_INVERT to the file <install_path>/.socet_xxx, where “xxx” is the name 
of the machine you are working on. This method will always perform the correction for 
all CCRS SPOT imports until you edit the .socet_xxx file and take the instruction out. 
The other way is to start the SPOT Import task manually by typing: 

 
% <install_path>/bin/start_socet -setenv_no_arg 
CCRS_ROLL_INVERT -single spot 1 xxx.prj 

 
where “xxx” is the name of your project. This method only performs the correction for 
that 
particular import session. 
Some SPOT images in the CCRS (Canadian) format contain an error in the sensor 
attitude data on the tape header, which make it impossible to control the image with 
SOCET SET. If you find this to be true, ask your tape supplier for a replacement tape. 
This is not a problem with SPOT tapes produced by the SPOT Image Corporation. 

 
Using SPOT images 

When creating a project which will include SPOT images, the geodetic datum must be 
based on an earth-centered ellipsoid such as WGS 84. The reason for this is that the 
SPOT satellite ephemeris and attitude data are based on an earth-centered system. Before 
importing your data, make sure your project has an origin near the center of your SPOT 
or JERS data set. It should be in the same hemisphere for Geographic projects, or the 
same UTM zone for UTM projects. 
 
Interior Orientation is not required with SPOT images, since the sensor is a digital 
camera, resulting in a known, fixed relationship between each image pixel and the sensor 
lens. 
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SOCET SET can accommodate images from different sensors simultaneously. From the 
user’s point of view, there is little difference between triangulating a block of frame 
images, SPOT images, or a mixture of both. When triangulating SPOT images, there are 
thirteen parameters which can be adjusted: the focal length, the 6 parameters of position 
and attitude, and the 6 first degree components of position and attitude with respect to 
time. A priority estimates for these are obtained from the SPOT header data. 
 
The recommended number of ground control points is 4–6 per model (or per multiple 
image strip if all images are from a single orbital pass.) Pointing accuracies range from 
6–20 meters. If there are no ground control points available, the expected absolute 
distance error is approximately 500 meters. A single control point can correct for model 
offsets due primarily to timekeeping errors. 
Two control points can correct for offset and azimuth errors. 
 

Outputs 
Outputs consist of an ASCII support file and a binary image file which is tiled with a 
header in a tiled format. The support file is created in the data directory used by the 
current project file. The display of support data is provided by the window popped-up 
from the main SPOT menu. 

 
 
Importing From CD-ROM 

SPOT Import recognizes the data format for SPOT Scene and CCRS CD-ROM products. 
On Unix, the CD-ROM must be mounted on the directory “/cdrom.” If this is not the case, 
ask your system administrator to mount it there. The root directory of the CD ROM must 
have subdirectories called “scene01,” “scene02,” etc. for each scene on the disk. If you 
have difficulty importing, you can also try identifying the files with the Importing From 
Disk interface. 
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Importing From Disk 
 
SOCET SET can use disk files for the SPOT data. There can be one single large file 
containing the Volume Directory File, Leader File, Imagery File, Trailer File, and Null 
Volume Directory File or these files can be kept separate. If the files have the SPOT 
Scene naming convention, e.g. vold_01.dat, lead_01.dat, imag_01.dat, trai_01.dat, 
null_01.dat, then you can click on just one of them and the rest will be filled in 
automatically. The disk file selection box also allows you to select more than one file. 
You can use this feature if you are having difficulty in importing a set of files and would 
like to try a different file ordering. The files are read in the order that you click on them. 
You can specify multiple files by clicking on them while holding the Control Key. 

 
Transferring Data From Tape to Disk 

You might want to transfer your data from a tape to disk so that it can be subsequently 
imported from disk on a different workstation. The steps to do this are as follows: 

1. Mount the 9-track CCT on a tape drive. In this example the device name of 
the tape drive will be /dev/rmt/7n. 

2. Use the <install_path>/bin/tape_struct executable to determine the files and 
record size. 

% <install_path>/bin/tape_struct /dev/rmt/7n 
As a result of this command the messages should reflect the file number and 
block size of the records in each file. 

3. Edit the <install_path>/bin/copy_spot_to_disk script to reflect the input 
record block size. This script file should reflect the following commands 
which must be correct in order to copy records verbatim to disk files 

 
dd ibs=360 if=/dev/rmt/7n of=vold_01.dat 

 
dd ibs=3960 if=/dev/rmt/7n of=lead_01.dat 

 
dd ibs=8640 if=/dev/rmt/7n of=imag_01.dat 

 
dd ibs=1080 if=/dev/rmt/7n of=trai_01.dat 

 
dd ibs=360 if=/dev/rmt/7n of=null_01.dat 

 
mt -f /dev/rmt/7n rewind 

 
Some older SPOT images were on two tapes at 1600 bpi for a single image. If 
there is a second tape involved, then repeat these first three steps for the second 
tape as well using _02.dat in place of _01.dat for the output files. 

 
Strip off the first 8640 bytes from part 2 of the image which is imag_02.dat using 
the following command: 
 

dd if=imag_02.dat of=strip_02.dat bs=8640 skip=1 
Second, you then concatenate the following input files into one output file: 

 
cat vold_01.dat lead_01.dat imag_01.dat strip_02.da 
trai_01.dat null_01.dat > scene1 
 

4. Now proceed to import the disk image file, as described under importing 
from disk. 
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                    Tips for Triangulating Particular Sensors 

SPOT Images 
Several sensor types are known generically as “pushbroom,” because of the 
method of collection, have unique characteristics that the user should be aware of. 
This includes the SPOT sensor and several of the National Technical Means 
(NTM) sensors. See “SPOT, JERS and IRS Import,” Chapter 11. These sensors 
continuously collect imagery as the sensor passes over the ground. Rather than 
store the entire image in one huge digital file, the data is broken into pseudo 
“frames” with overlap regions created to allow later triangulation into a 
consistent block. The problem develops because the overlap areas are, in fact, the 
same image with the same exposure station parameters. To determine the 
elevation of a point (Z) the software projects a ray through an image point in one 
image and intersects the ray with the same point in the overlapping image. In this 
case the two rays are parallel and never intersect causing the z value calculation 
for the point measurement to fail. The x,y values of the sample are still valid for 
connecting the images together but the z is worthless. When the solution function 
attempts to adjust the ground positions it fails as well. The problem can be 
avoided by changing the tie points between these pseudo images to “Vertical” 
type control points. This treats the point as a Z control point and does not try to 
adjust the Z image parameters. The x,y adjustments are done as usual to tie the 
pseudo frames together. An additional tie point between strips is still needed (if 
there are multiple strips in the block) to connect adjacent images, since these are 
independent and do not share the same exposure location values. If you have 
SPOT 5 images without control, try the second degree attitude (q0_0, q1_0, q2_0, 
q0_1, q1_1, q2_1, q0_2, q1_2, q2_2) to a small sigma value, e.g. 0.00001. 
Disable all other parameter adjustments. 
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3.1 Triangulation 

3.1.1 Preparation 

3.1.1.1 Create new Datum (e.g. PRS92) and Grids (e.g. PTM and 
 UTM) 

 
To add a new datum or grid, the ASCII files in this directory 
(C:\SOCET_SET_5.3.0\Internal_dbs\ 
GEODETIC) must be edited before running Create Project. 

 
 
 

SUMMARY OF FILES OF GEODETIC.DAT AND GRID_PARAMETERS 
---------------- 
geodetic.dat    - Contains numerical definitions of all 
datums, including names. 
                - *****   N O T E : ***** 

Do not change any of the datum names 
contained in this file!!! 

                  *********************** 
grid_parameters - Defines grid coordinate systems (state 
plane, etc.) 
geoid84.dat     - Defines mean sea level geoid; Binary 
(non-ASCII) file 
ellipsoid.dat   - Defines reference ellipsoids 
geodetic.doc    - For reference only; not used by SOCET SET 
software 
 
 
 
DATUMS 
------ 
 
To create a new datum, you must add the appropriate 
information to file geodetic.dat 
 
 -  *****  N O T E : ***** 
    Restrict new datum names (including the ID NUMBER) 
    to 80 characters or less. 
    ********************** 
 
The values for each datum in the geodetic.dat file are 
arranged in pairs of lines.  The values for each column are 
as follows. 
 
 
 
Line 1:   Num D_name 
          --- ------ 
 
Line 2:   E_code A F dA dF*10^4 dX eX dY eY dZ eZ G_code s 
rX rY rZ use_approx 
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          ------ - - -- ------- -- -- -- -- -- -- ------ - 
-- -- -- ---------- 
 
The last 5 values (s, rX, rY, rZ, use_approx) are optional. 
 
Num = serial number of the entry within the file. 
D_name = name of the datum (sometimes abbreviated, 
         should be 80 characters or less). 
E_code = 2 character code for the reference ellipsoid 
corresponding to this datum 
A = equatorial radius (semi-major axis) in meters. 
F = flattening (defined below). 
dA = difference between this datum's radius and 
WGS84_radius            (reference only)  
dF*10^4 = difference between this datum's flattening and 
WGS84_flattening multiplied by 10,000 (reference only). 
dX, dY, dZ = offset of this datum's ellipsoid with respect 
to the centroid of the earth (WGS84), expressed in meters. 
eX, eY, eZ = error estimates for the datum offsets (+ or -, 
             expressed in meters). 
G_code = EPSG Geographic CS Type Codes, Based on EPSG Datum. 
         Numbers 4200-4999: valid codes 
         Number 0: undefined 
         For details, see the website: 
         
http://www.remotesensing.org/geotiff/spec/geotiff6.html#6.3
.2.1 
s = scale for 7 parameter transform. 
rX, rY, rZ = Rotations for 7 parameter transform. 
use_approx = if 0 use rigorous 7 parameter transform 
             if 1 use approximate 7 parameter transform 
 
NOTE:  Use meters to specify earth radius and XYZ offsets. 
DO NOT USE FEET. If you are working in a feet-based project, 
the conversions will be performed automatically for you by 
SOCET SET.  Use radians to specify rotation. 
 
 
The file 'geodetic.doc' is provided for reference and is 
not used by the workstation. However, you should add an 
entry to the geodetic.doc file,for reference purposes. 
 
 
 
GRIDS 
----- 
The file "grid_parameters" defines the various grids the 
operator may choose from when running the Project Creation 
function in SOCET SET. 
This file is used by the Project Creation process to create 
a menu for the operator to select a grid.  A grid must be 
added 
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to this file BEFORE running the project creation process if 
you want to use the grid. The format of the file is defined 
in comments in the file itself. 
 
A grid is a localized coordinate system based on a map 
projection that is well suited to the local region.  Every 
state has one or more grids defined, called 'State Plane' 
coordinate systems. 
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EARTH SHAPE 
----------- 
The oblateness of the earth may be expressed three 
different ways: 
 
  flattening           = (a-b)/a; 
  eccentricity         = sqrt (  (a**2  - b**2)  / a**2  ); 
  eccentricity_squared = (a**2  - b**2)  / a**2; 
 
Where a = equatorial radius, and 
      b = polar radius. 
 
To compute ecc_squared from flattening, use this formula: 
 
    ecc_squared = f * (2 - f); 
 
 
 
FEET VS. METERS 
--------------- 
All distances in these files are measured in METERS.   
Distance values include: 
 
    - the earth radius 
    - XYZ offset of the datum 
    - XYZ offset error estimates of the datum 
    - false easting and northing 
 
Do not use FEET units in these files!!  If the coordinate 
system you are using is feet-based (as are many State Plane 
systems) don't worry: enter the data (false easting and 
northing) in these files in METERS, then select "Units = 
FEET" during the project creation process. Thereafter, all 
your input and output will be in FEET units.  For more 
information, see the Project Management chapter of the DPW 
SOCET SET User's Manual. 
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Sample file of geodetic.dat  
 
VERSION 1.0 
######################################################################
######## 
# 
# DO NOT CHANGE THE FIRST LINE (the 'VERSION' line) 
# 
# This file contains the parameters for specifying datums. 
# Parameters for the standard datums are taken from 
# NIMA document "Department of Defense World Geodetic System 1984, 
# Its Definition and Relationships with Local Geodetic Systems", 
# TR8350.2, Third Edition, Amendment 1 (3 January 2000), 
# Appendices A.1, B.1-B.10 and C.1-C.2. 
# 
# NOTE:  This file replaces old versions of both datum.dat 
#        and geodetic.dat. 
# 
# You can add lines to this file, to specify other datums, if you 
# wish.  If you do, be sure to follow the existing format.  The 
# values for each datum in this file are arranged in pairs of lines. 
# See internal_dbs/GEODETIC/README for the format. 
# 
######################################################################
######## 
  1  WGS_72 
     WD  6378135.00000  0.0033527795         2.000   0.00031000     0.0   1.0     0.0   1.0     
0.0   1.0  4322 
  2  WGS_84 
     WE  6378137.00000  0.00335281066475     0.000   0.00000000     0.0   1.0     0.0   
1.0     0.0   1.0  4326 
  3  [ADI-M]_ADINDAN(Mean_Solution) 
     CD  6378249.14500  0.0034075614      -112.145  -0.54750714  -166.0   5.0   -15.0   
5.0   204.0   3.0  4201 
  4. PHILIPPINE_(PPCS) 
     CC  6378206.40000  0.00339007530393   -69.400  -0.37264639  -127.6220 0.0  -
67.2448 0.0 
   E code          A                                       F                             dA              dF*10^4                   
dX        eX          dY         eY 
  -47.0431 0.0     0  0.99999893998  0.000014872241633  -0.000023769979580  - 
       dZ        eZ  G_code       s                             rX                                    rY 
0.000007649875327  1 
            rZ               use_approx 
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Sample file of ellipsoid.dat 
 
 
VERSION 1.0 
############################################################ 
# 
# 
# 
# DO NOT CHANGE THE FIRST LINE (the 'VERSION' line) 
# 
# 
# 
#  This file contains reference ellipsoid names and their  
#  associated constants.  Refer to NIMA document TR8350.2,  
#  Third Edition, Amendment 1, 3 January 2000,  
#  "Department of Defense World Geodetic System 1984",  
#  Appendix A.1 
# 
#  You can add entries to this file if you desire.   
#  When doing so, please use the following guidelines. 
# 
#  1.  Use underscores (_) instead of spaces in all 
#      ellipsoid names. 
#  2.  Make sure that you specify a unique 2-character 
#      ID code for the new ellipsoid.  This will be  
#      the same code that you will use in file  
#      geodetic.dat for any datums that will use the 
#      new ellipsoid. 
#  3.  If you want to specify subclasses of ellipsoids 
#      (similar to the Bessel 1841 and Everest 
#      ellipsoids), the first character of the  
#      subclass line must be a space. 
#  4.  Equatorial radius, flattening and eccentricity 
#      squared values are included in this file for 
#      reference, but are not used by the software. 
#      It is not critical that these values be 
#      accurate in this file. 
# 
############################################################ 
# 
# 
# Ellipsoid Name                                  ID Code   Equat. Rad(a)  Flattening(f)      
Ecc_squared 
# --------------                                     -------   -------------         -------------         ----------- 
# 
Airy_1830                                              AA      6377563.396    0.003340850641      
0.006670539999 
Australian_National                                          AN       6378160.0       0.0033528918692    
0.0066945418545 
Bessel_1841 
  Ethiopia,_Indonesia,_Japan_and_Korea       BR      6377397.155    0.003342773182      
0.006674372231 
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  Namibia                                                          BN      6377483.865    0.003342773182      
0.006674372231 
Clarke_1866                                                     CC     6378206.4        0.00339007530393   
0.00676865799729 
WGS_1972                                                       WD    6378135.0        0.0033527795           
0.0066943179 
WGS_1984                                                       WE     6378137.0       0.00335281066475   
0.00669437999014 
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Sample file of grid_parameters 
 
 
######################################################################
### 
# 
# 
# 
# DO NOT CHANGE THE FIRST LINE (the 'VERSION' line) 
# 
# 
#  This file is the grid file.  This file defines the various grid coordinate 
#  systems that the operator may select when creating a SOCET SET project. 
#  This file is used by several SOCET SET applications: 
# 
#   a) Project Create (selecting a Grid coordinate system) 
#   b) Coordinate Measurement - CoordinateTransformation subwindow 
#   c) Annotation - Gridlines / Ticks 
#   d) Control Point Measurement - data entry coordinate system 
#   e) Triangulation - Interactive Point Measurement 
# 
#  ADDING GRID DEFINITIONS TO THIS FILE 
#  --------------------------------------- 
#  If you want to create a grid coordinate system and use it in SOCET SET, follow 
#  these steps: 
# 
#    1) Edit this file.  Add your new grid definition into this file. 
#       It is usually easiest to copy an existing grid definition and change it 
#       rather than typing-it in from scratch. 
#       You may add your grid anywhere in this file after the first "VERSION" line. 
#       Most users find it most convenient to place their grid as the first coord system. 
# 
#     2) You can delete other grid definitions out of this file if you want to. 
# 
#     3) Save this file back into /usr/geoset/internal_dbs/GEODETIC/grid_parameters 
# 
#     4) Start SOCET SET.  When you run Project Create, you will see your Grid in the 
#        the list of grids when you select the Grid option under Coordinate Systems. 
# 
# 
# 
# 
#  FORMAT OF GRID DESCRIPTOR 
#  ------------------------------ 
#  Each grid is described in three sections: 
# 
#   (1) The first line describes the grid name and datum info. 
#       The grid name follows the keyword GRID_TYPE and may be any string you like: 
#       it sole purpose is to distinguish between the various grids in this file. 
#       The values for DATUM_NAME, DATUM, OFFSET and ERROR are those 
contained 
#       in file geodetic.dat for the datum in question. 
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#     The numbers on this line can be in scientific notation (e.g. 6.69E-03) or in normal 
#     floating point notation (e..g 0.00669). 
# 
#     The XYZ offset is measured from the center of the WGS_84 ellipsoid (Z axis up thru 
#     North pole; X axis thru Greenwich meridian;  Y axis thru +90 degrees longitude). 
# 
# 
#   (2) The middle lines describe the projection.  The possible projections are: 
# 
#    TRANSVERSE_MERCATOR_PROJECTION 
#    CASSINI_SOLDNER_PROJECTION 
#    HOM_PROJECTION  (Hotine) 
#    LAMBERT_CONFORMAL_PROJECTION 
#    MERCATOR_PROJECTION 
#    POLAR_STEREOGRAPHIC_PROJECTION 
#    POLYCONIC_PROJECTION 
#    STEREOGRAPHIC_PROJECTION 
#    TRANSVERSE_MERCATOR_PROJECTION 
#    UTM_PROJECTION 
#    NEW_ZEALAND 
#    SINUSOIDAL_PROJECTION 
# 
#       Each projection has a 2 to 4 lines of definition. 
#       The content varies depending on the projection.  The syntax 
#       for each projection is described below in the "sample" grids. 
#       For example, for UTM: 
# 
#                         keyword 
#                         defining the 
#                         projection 
#                             | 
#                             V 
#          PROJECTION_TYPE UTM_PROJECTION 
#          ZONE 1 
# 
# 
#   (3) The last line holds false easting and false northing (in meters). 

Grid 
Name 
 

Name 
Of 

Datum 

Earth 
Equatorial 

Radius 
Eccentricity

Squared 

XYZ offset 
From earth 

center 

Error 
estimates of 
XYZ offset 
From earth 

center 

GRID_TYPE al_e_27 DATUM_NAME [NAS-C]_NAD_27(CONUS) DATUM   6378206.4  0.00676865799729  OFFSET -8 160 176  ERROR 5 5 6 
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#       These are positive offsets added to the projection coordinates to force 
#       most values to be positive.  Generally, the Positive and Negative 
#       false eastings are identical. IMPORTANT: If your grid does not 
#       work properly, make the first and second numbers the same and 
#       the third and fourth numbers the same, e.g. 
# 
#        F_NORTH_POS 10000000 F_NORTH_NEG 10000000 F_EAST_POS 500000 
F_EAST_NEG 500000 
# 
# 
 
#  FEET VS. METERS 
#  ------------------- 
#  All distances in this file are measured in METERS.   Distance values include: 
# 
#      - the earth radius of the datum 
#      - XYZ offset of the datum 
#      - XYZ offset error estimates of the datum 
#      - false easting and northing 
# 
#  Do not use FEET units in this file!!  If the grid coordinate system you 
#  are using is feet-based (as are many State Plane systems) don't worry: 
#  enter the data (false easting and northing) in this file in METERS, then 
#  select "Units = FEET" during the project creation process.  Thereafter, 
#  all your input and output will be in FEET units.  For more information, 
#  see the Project Management chapter of the SOCET SET User's Manual. 
# 
# 
#  FALSE EASTINGS AND NORTHINGS 
#  -------------------------------- 
#  XY Coordinate values in a grid coordinate system are often negative (e.g. 
#  X values are negative to the West of the origin point).  However, many grids 
#  are defined to force the XY values to be always positive.  This is achieved NOT 
#  by moving the origin point, but rather by adding artifical offsets to the 
#  mathematically correct XY values.  These offets are called "false northing" and 
#  "false easting".  These are usually large positive numbers. 
# 
#  There are two false values for X: false easting positive and false easting 
#  negative.  The former is used when the X value is positive, and the latter 
#  when the X value is negative.  The same for Y:  false northing positive and 
#  false northing negative. 
# 
#  The false easting positive and false easting negative should be identical 
#  (we are not aware of any coordinate system in which they differ). 
# 
#  The false northing positive and false northing negative are usually identical, 
#  but will be different in some rare cases.  For example, the UTM grids 
#  (transverse mercator, with origin at the equator) use different values 
#  for false northing positive and false northing negative. 
# 
#  The false eastings and false northings are always defined in this file in 
#  meters, even if you are defining a feet-based grid. If you are using a 
#  feet-based grid, you may find the following conversion 
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#  table useful  (note: these values are based on the 
#  International Foot definition; if you are using the U.S. Survey Foot, these 
#  values are not valid): 
# 
#         FEET        METERS (use in the grid definition below) 
#        -----------  ---------------------------------------- 
#          100,000      30,480 
#          500,000     152,400 
#        1,000,000     304,800 
#        2,000,000     609,600 
# 
# 
 
#  LATITUDE / LONGITUDE 
#  ---------------------- 
#  All latitude and longitude locations are specified in radians, not degrees. 
#  Degrees WEST of Greenwich are expressed as NEGATIVE radians.  For example, 
#  118 degrees west is represented as  -2.059488517353309  radians. 
#  If you have a location in degrees, and you need to convert it to radians, use 
#  the degree-to-radian conversion program (activated under the Tools menu on the 
#  main SOCET SET menu). 
# 
# 
#  SCALE REDUCTION FACTOR: 
#  ----------------------- 
#  The central scale factor is another way of expressing a scale reduction: 
#  e.g. a scale reduction of 1:10,000 corresponds to a scale factor of 0.9999 
#  This is used in transverse mercator, hotine oblique mercator, and 
#  stereographic projections. 
# 
# 
#  STATE PLANE DATUMS 
#  --------------------- 
#  The entire Unites States is covered by 122 grids called the State Plane grids. 
#  There are two versions of the State Plane grids:  an older set based on the NAD 27 
#  datum and a newer set based on the NAD 83 datum.  This file contains both 
#  the old and the new state plane systems.  For example, California Zone 6 is 
#  ca_6 (old, NAD-26) and ca_6_83 (new, NAD-83).  For reference, the two datums 
#  used for State Plane grids are: 
# 
#       Datum       Equa.Radius    ecc_squared      XYZ offsets             XYZ Accuracies 
#       ---------   ------------   ------------     ---------------------   -------------- 
#       NAD 27      6378206.4      0.00676865799729     -8.0   160.0   176.0    5   5   6 
#       NAD 83      6378137.0      0.00669438002290      0.0     0.0     0.0    2   2   2 
# 
# 
#  COMMENT LINES 
#  ------------------- 
#  All lines in this file beginning with '#' are treated as comments and ignored. 
# 
# 
#  ECCENTRICITY AND FLATNESS 
#  --------------------------- 
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#  The oblateness of the earth may be expressed three different ways: 
# 
#    flattening           = (a-b)/a; 
#    eccentricity         = sqrt (  (a**2  - b**2)  / a**2  ); 
#    eccentricity_squared = (a**2  - b**2)  / a**2; 
# 
#  Where a = equatorial radius, and 
#        b = polar radius. 
# 
#  To compute ecc_squared from flattening, use this formula: 
# 
#      ecc_squared = f * (2 - f); 
# 
# 
#   GEOTIFF 
#   ------------- 
#   Each grid definition may  be followed by an optional GeoTiff ID number line. 
#   The format is: 
#       GEOTIFF  <id_number> 
#   This line is optional, and if it does appear, it must be the final line 
#   of the grid definition.   The ID numbers are obtained from the GeoTiff 
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3.1.1.2 Establishing the path/directory where the images are to be 
 located. 

 
Before you can import or display imagery with the software, you must 
create a project. You can think of a project as a container holding the 
data for a set of images you are going to utilize. The data you extract 
from a set of imagery will be stored in the project directory that contains 
that set of imagery. When you create a project, you specify the 
coordinate system and datum to use for the project. You also will specify 
the disk directories of where the project and imagery data will be stored. 
Most importantly, you give your project a name. The name of the project 
file is the name you assigned to the project with the extension.prj when it 
was created. The software stores the definition of a project in a special 
project file. 
SOCET SET uses the computer file system to store its project data. The 
following figure depicts the directory tree the software uses to store its 
data. 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
Most software applications require that you first load a project. Once you 
have loaded a project, you can then operate on the imagery and other 
data contained therein. You can import images into the project, 
triangulate the images, perform feature and terrain extraction, and create 
image products to export. The locations of the image files are defined by 
entities called Image Locations. 
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1.  Create the path/directory location of the image file. 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

2.  Open “SOCET SET 5.3.0”. Click ”Project”, select 
“Create/Edit Project” 

 
 
 
 
 
 
 
 
 
 
 

3.  A “Create/ Edit Project dialog box will appear. Click the 
browse  button in the “Location “box. 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

4. A “File Location” dialog box will appear. Click “Edit 
Locations”  button 
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5.  A “location.list-WordPad” dialog box will appear. Type 
the directory (e.g. C:\SOCET_SET_5.3.0\images\spot). 
Then click “Save” . 
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3.1.1.3 Creating Project. 

You use Create/Edit Project to create your project. Since most SOCET 
SET applications require a project to be loaded, you must create a 
project before you can proceed with importing and extracting data. 

 
1.  Click “File”, select “New”. 
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2. Click the down arrow  in the “Coordinate System” box 
and select “Grid / State Plane”. 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

3. A “Select a Coordinate System” dialog box will appear. 
Scroll down the arrow and select the desired coordinate 
system (e.g. Philippine_UTM_51N). Then click “OK”. 
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4. Click the browse  button in the location box. A “File 
Location” dialog box will appear. Select the image file 
location [e.g. spot (211451.2mb)] Then click “OK” 

. 
 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

5. Type 0 in the “Minimum Ground Elevation (estimated) 
box and 1800 in the Maximum Ground Elevation 
(estimated) depending on the highest elevation of the 
project area. Click “File”, then click “Save”. 
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6. A “Project Name Selection” dialog box will appear. Type 
the desired project name (e.g. monospot) in the “Enter 
Project Name” box. Then click “OK” . 

 
 
 
 
 
 
 
 
 
 

 
7. Check the bottom box of the “Create / Edit Project“ dialog 

box, if the project “carto_stereo” was created. 
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3.1.1.4 Importing the Image (SPOT DIMAP) 

If you are importing SPOT data with three bands, you will see a “All 
Bands (color)” the three bands will be merged into a single color (3-
band) image file. The name of the support file will be what you entered 
in the name box. If you select “All Bands (grays)” the three bands will 
be put out as three separate monochrome images. The name of the 
support file(s) will be what you entered in the name box concatenated 
with “_band_n.sup,” where “n” is “1” “2” or “3” for the three bands. If 
you select “Band n only,” it will behave the same as “All Bands 
(grays),” except only the single band you select will be imported. For 
SPOT4, four bands are available. 

 
 

1. Click “File”, select “Load Project”. 
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2. A “Select Project File” dialog box will appear. Select the 
project name (e.g. carto_stereo.prj) that was created. Then 
click “OK” . 
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3. Click “Preparation”, select “Import”, select “Image” and 
then click “SPOT DIMAP”. 
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4. A SPOT DIMAP IMPORT<monospot.prj> dialog box 
will appear. Put mouse arrow inside the ‘”DIMAP files 
box and click right mouse button. Click the “Add” button. 

 
 
 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

5. A “Select one or more files to add” dialog box will appear. 
Use the down arrow  in the “Look in” box, browse and 
locate the image file (e.g. METADATA.DIM) to add. 
Then click “Open” . 
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6. The selected image file will be reflected in the “DIMAP 
Files” box. Set Format to TIFF TILED. Then click “Start” 

. 
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7. See information at the bottom box and check if import is 
complete. 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

8. After importing the image, click “File”, select “Load 
Images”. 
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9. An “Image Loader” dialog box will appear. Click “Create” 
 to create a view window. Select the first 

image file (e.g. 53033190611210220512AL) in the left 
file box and select the second image file (e.g. 
53043200604260240041AR) in the right file box. Then 
click “Load”. 
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10. A view window will appear displaying the imported image 
(e.g. SPOT). 
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3.1.1.5 Importing the Image (Index Map_Control Point) 
 

1.  Click “Preparation”, select “Import”, select image, and 
click “World File”.  

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

2. An “Image Import” dialog box will appear. Put mouse 
arrow inside the “Input Image Files” box and click right 
mouse button. Click the “Add” button. 
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3. A “Select one or more files to add” dialog box will appear. 
Use the down arrow  in the “Look in” box, browse and 
locate the image file (e.g. 
Index_Map_2007may_spot_stereo.tif) to add. Then click 
“Open” . 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

4. 4The selected image file will be reflected in the “Input 
Image Files” box. Click “Georeferencing”. 
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5. A “Georeference Data” dialog box will appear. Select 
“Other” under “Source” column. Click “Select World 
File”. Click right mouse button.  

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

6. A “World File Selector” dialog box will appear. Select the 
required world file (e.g. 
Index_Map_2007may_spot_stereo.tfw). Then click 
“Open”. 
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7. The world file parameters will be reflected in the 
“Georeference Data” dialog box. Then click “OK”. 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

8. Set Image Format to JPEG 2000. Then click “Start”. 
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9. After importing the image 
(e.g.Index_Map_2007may_spot_stereo.tif) is done, click 
“File”, select “Load Images”. 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

10. A “Image Loader” dialog box will appear. Click “Create” 
 to create a view window. Select the image file 

name (e.g. Index_Map_2007may_spot_stereo) and click 
“Load”. 
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11. A view window will appear displaying the imported image 
(e.g. Index_Map_2007may_spot_stereo.tif). 
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3.1.2 Import Ground Controls  
 

Ground Point Import reads ground point data in an ASCII format into the 
internal Ground Point File Format. The input ASCII file is restricted to one 
ground point per line. Each ground point contains a point ID along with an 
(X,Y,Z) coordinate. This information can be in any order, but it must all be on 
one line.Obtaining this window is as simple as clicking Preparation > Import 
>ASCII Ground Point Import on the main workstation. 

 
 
 
 
 
 
 
 
 
 
 
 
 
 

Ground point control types of horizontal, 3-dimensional, and vertical are used 
within SOCET SET. Ground points which have a value of 0.0 exactly will cause 
the control point type setting to change. If your data has a control point of 0.0 0.0 
3.2, the point type will be set to vertical (Z only). If your data has a value of 
2456.8 23778.9 0.0, the point type will be set to 
horizontal (X and Y only). 

 
You use ASCII Ground Point Import to translate and import ground point data 
from an external source into the native SOCET SET ground point file format. 
The units of the data can be either decimal for UTM, grid, LSR, or Geographic 
projects (see below), or degrees minutes seconds for any project. Degrees 
minutes seconds must be entered as “+-DD:MM:SS.SSS”. The presence of two 
colons is mandatory. When you create a Geographic project, you specify a 
preference for coordinate display. If you import a file with decimal numbers into 
a Geographic project whose display preference is “dd.dddd” the numbers will be 
interpreted as decimal degrees. For all other Geographic projects, decimal 
numbers will be interpreted as radians. 

 
 

Edit Input Format Option 
This window provides you with a way to specify the order of the information in 
the input file. Click Options > Edit Input Format on the ASCII Ground Point 
Import window. You can save this ordering in an input format file for later use 
with other ground point files. 
The Fields column on the right of the ASCII Ground Point Import window 
(above), indicates the current order. To change a field setting, select the desired 
format from Format Selection on the left. Then click on the appropriate field on 
the right.  
There are seven format settings from which to select: ID, X, Y, Z, Code, Ignore, 
and Illegal. 
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• “Code” has no meaning for ASCII Ground Points. 
• “Ignore” is used to ignore any information that may be specified in a 

field. 
• “Illegal” indicates that a field should not contain any information. The 

entire point is discarded should any information be found in a field 
marked as “Illegal.” The following are some examples of legal 
settings for the input fields. 

 
 
 
 
 
 
 
 
 
 
 
 
 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

3.1.2.1 Edit Ground Control Points file. 
 

The GPS Ground Control Points file has several Field columns that need 
to be edited based on the seven Field  column Format settings (ID, X, 
Y, Z, Code, Ignore, and  Illegal) being used in SOCETSET.  

 
1. Open GPS Ground Control Points (text file) in Excel. 

 



IV-3-44 
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2. Delete unnecessary Field Columns. Then  
save file to *.csv format. 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

3.1.2.2 Import edited Ground Control Points File. 
 

1. Click “Preparation”, select “Import, and click “ASCII 
Ground Point”. 
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2. An ASCIII Ground Control Point Import dialog box will 
appear. Click the browse button in the “Input File 
Format’” box. 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

3. Another ASCIII Ground Control Point Import dialog box 
will appear. Select “Default.gcp”. Then click “Save”. 
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4. Click the browse button in the “Input ASCII Ground 
Control Point File” box. 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

5. An “ASCIII Ground Control Point Import” dialog box will 
appear. Click the down arrow, browse and locate the 
directory where the gcp text file is located. Select the file 
(e.g. “gcp_list.txt”). Then click “Open”. 
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6. Click “Options”, select “Edit Input Format”.  
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

7. An “Edit Input Format” dialog box will appear. Select the 
settings in the “Format Selection” box the fields (e.g. ID, 
X, Y, Z) that were used in your gcp text file. Then click 
“OK”. 
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8.  Type output ground point file name (e.g. gcp_spot) in the 
“Output Ground Point File” box. 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

9.  Click “Options”, select “Set Accuracy”.  
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10. A “Set Accuracy” dialog box will appear. Type “7” in  “X 
Accuracy” box, type “7” in “Y” Accuracy” box, and type 
“10” in “Z Accuracy” box. The values are the handheld 
GPS accuracy level in XYZ. Then click “OK”. 

 
 
 
 
 
 
 
 
 
 
 
 
 

 
 

11.  Click “Start”. Check the bottom box if conversion was 
successful. 

 
.  
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3.1.2.3 Using Control Point Editor 
 
Control Point Editor creates a file of control points, which are used by 
Triangulation. Use the Control Point Editor to create, view, edit, or 
change a file of control points. 
 
One of the important features of the Control Point Editor is that it lets 
you input the control point data in one coordinate system, and save the 
file in a different coordinate system. Selecting an alternative datum 
changes the display and input values. These are converted to/from the 
underlying project datum for storage in the .gpf file. This could be used, 
for example, when you have a pair of well-controlled images in a UTM 
project, but you want to collect control points for a State Plane project. 
The major capabilities of the Control Point Editor are as follows: 

• Creates a new ground point file or modifies an existing ground 
point file. 

• Saves the ground control points to the current project or a 
different project. 

• Converts the list of points to any project’s coordinate system 
and datum. 

• Measures (in three-dimensional space) ground points from 
controlled imagery. 

• Drives the extraction cursor to a three-dimensional ground 
point location for any point in the list. 

• Displays and accepts control point data in the current project’s 
coordinate system or an arbitrary coordinate system and datum. 

There are four ways to build a file of control points: 
• The Control Point Editor, 
• The Interactive Point Measurement window of Triangulation, 
• Ground Point Import, and 
• Coordinate Measurement Log. 

If you decide to use Control Point Editor for inputting your control 
points, you should run it after you create a project, but before running 
Triangulation. If you are going to use well-controlled imagery (e.g. 
PPDB) to fabricate control points, you must import the well-controlled 
images before running Control Point Editor. 
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1.  Click “Preparation”, select “Control Point Editor”. 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

2. A “Control Point Editor” dialog box will appear. Click the 
browse button in the “Ground File” box. 
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3. A “Select Ground Point File” dialog box will appear. 
Click the down arrow button in the “Look in” box and 
locate the folder of the imported ground control point. 
Then click “Save”. 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

4. The GCP point ID will be reflected in the Point ID box. 
Select one point ID (e.g. RM 112), the coordinates XY 
and elevation Z will be shown in the Coordinates box. 
Click down arrow and select “Z Cntrl”. Change all “XYZ 
Cntrl” type of leveling point id to “Z Cntrl”. Edit the 
Accuracy values with respect to X/Long, Y/Lat, and Z.. 
Select another point ID and edit the accuracy. Repeat the 
procedures until all the needed point ID have been edited.   
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5. Click “File”, select “Save GPF”.  
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3.1.3 Measurement of Image Coordinates (Points) 
 
There are four ways to measure ground points in imagery: 

• Automatic Point Measurement (APM) (in Triangulation) 
• Interactive Point Measurement for APM 
• Interactive Point Measurement (IPM) for Blunder Detection 
• Interactive Point Measurement for Simultaneous Solve 

The decision of whether to run IPM before of after APM depends on the kind of 
ground points you have. The following table gives some guidance: 

 
WHAT TO RUN SITUATION 

 
APM before IPM You have a few control points; and you want to Solve 

(after APM) before running IPM so that it is easier to 
find the control points in IPM. 

IPM before APM    You measure some control points and some tie points in 
IPM (in one image only), then you run APM to transfer 
these points to other images  and  to measure 
additional tie  points. 

IPM only                  You have just one image. Or, you have lots of control 
points and you don’t need tie points. 

APM only                You have no control points. To interactively review the 
tie points measured by APM, you use IPM. Neither APM 
or IPM You have measured the image points on an 
analytical plotter, and imported them with ASCII Image 
Point Import, and are using Triangulation only for the 
Solve process. 

 
Control Points are points with known ground coordinates (XYZ, or XY, or Z). 
You must enter the location into the IPM window. Triangulation stores this data 
in the project Ground Point File. You must also use the extraction cursor to 
identify the control point in all the images in which the point is located. The 
image space positions are stored in the Image Point Files (IPF). 

  
Tie Points are points on the ground that you can identify in two or more 
overlapping images, but you don’t know the ground coordinate. You use the 
extraction cursor to identify the point in all the overlapping images. The image 
locations are stored in the Image Point Files (IPF). An entry is created in the 
Ground Point File (GPF) for each tie point. APM will create tie points 
automatically. 

 
Check Points are points with known ground location (XYZ) that are not used in 
the solution, but are provided to help the operator perform a quality control 
check after the solution is complete. Check points are also called diagnostic 
points. 

 
Ground Point is an umbrella term that includes Control Points, Tie Points, and 
Check Points. 

 
Image points are the image space locations (in lines and sample                
coordinates) of Ground Points.  A single image point is stored for every instance 
of a ground point in an image. For example, if a tie point is located in 4 
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overlapping images, and you measure it in 3 of the images, then 3 image points 
are stored. Image points are stored in the IPF files. An image point must be 
associated with some ground point. If you somehow have points in IPF files 
which are not reflected in the GPF file, transfer them using the Reset > Transfer 
Image Points menu selection. 

 
Ground Point Selection 
Ground Point consists of two tables containing ground point information. The 
upper table lists all ground points in the current Ground Point File. Clicking the 
LMB on any point in the table moves the extraction cursor to that point and loads 
the measured and unmeasured images. 

 
Image Point Section 
This area contains the image status list which displays all images containing the 
selected ground point. The point status is either locked or unlocked, measured or 
unmeasured. An X in the appropriate field indicates locked or measured. The 
Master field indicates which images are loaded left or right. The left master 
image is always used as the master when Auto Two or Auto All is selected. 

3.1.3.1 Opening an Automated Triangulation file. 
  

1. Click “Preparation”, select “Multi-Sensor Triangulation”.  
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2. An “Automated Triangulation” dialog box will appear. 
Click “Setup”.  

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

3. A “Setup” dialog box will appear. Click “Advanced”.  
Click “Rigorous Simultaneous” in “Solution Type”. 
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4. A “Setup” dialog box will appear. Click “Add” 

.  
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

5. A “Strip ID Sequence” box will appear. Type a number 

(e.g. 1). Then click “OK” . 
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6. A “Select Support File(s)” dialog box will appear. Select 
the images (e.g. 53033190611210220512AL.sup and 
5304320060426240041AR.sup) in the “Available” box. 
Click the arrow  to copy the selected image to the 

“Selected” box. Then click “OK” . 
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7.  The created strip 1 will be reflected in the “Strips” box 
and the selected images (e.g. 
53033190611210220512AL.sup and 
5304320060426240041AR.sup) will be reflected in the 
“Images” box. Click “OK”. 
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8. Click ”Settings” and select “Enable Multi-Image Display.  
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9. Click ”Settings”, select “Graphic Display”. 
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10. A “Graphic Display” dialog box will appear. Check “Tie” 
box, “Control” box, “Icon” box, and “IDs” box. 
Click ”Apply” . Then click “Close” 

. 
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11. Click ”Interactive Point Measurement”.  
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

12. An ”Interactive Point Measurement” dialog box will 
appear. 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

13.  
S
elect a Point ID (e.g. RM-112). Put arrow inside Image 
Points box, click right mouse button and select “Add”. 
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14. A “Select Image to Add” dialog box will appear. Select 
the needed images (e.g. 53033190611210220512AL.sup 
and 5304320060426240041AR.sup). Then click “OK”. 

 
 

 
 
 
 
 
 
 
 
 
 
 
 
 

15. The position of selected point ID (e.g. RM-112) will be 
shown on the image. Using the Description of Bench Mark 
as reference, move the cursor if necessary to adjust the 
location of the control point. 
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16. Once you have moved the cursor to the exact location, 
check the “Lock” box of the first Image ID (e.g. 
53033190611210220512AL). Click “Auto Two” button if 
the image point Id is within two or more images. Click 
“Save”.  

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

N
o
te: If control point is only within 1 image, just click 
“Sample” and then click “Save” 

 
17.  Repeat steps 13 and 16 until all the required gcp’s have 

been measured. 
 

 
 
 



IV-3-69 

3.1.4 Calculation/Inspection 

3.1.4.1 Simultaneous Solve. 
 
Simultaneous Solve performs a rigorous triangulation adjustment of a 
block of images to refine the estimates of their Triangulation parameters. 
Simultaneous Solve uses the weighted least squares method of 
adjustment in an iterative manner. It is capable of simultaneous 
adjustment of blocks of images taken by different sensors such as frame, 
panoramic, etc. It is also capable of recovering the interior geometry of 
the sensors via added parameters. 
 
Simultaneous Solve requires the following input: image coordinates of 
control and tie points and their accuracies (image point files), ground 
coordinates of control points and their accuracies (ground point file), 
estimates of Triangulation parameters and their accuracies (support files 
and Triangulation file), and the interior geometry of the sensors (support 
files). All these data are automatically accessed by Simultaneous Solve 
without your intervention. 
 
Simultaneous Solve uses a method known as “bundle adjustment” to 
determine the set of individual image parameter coefficients that 
minimizes the relative line/sample differences between points measured 
in overlapping images. The goal is to adjust the image parameters so that 
the position of a point in one image corresponds to the same point 
position in the other. If ground control is included, the parameters are 
adjusted so that the same image point corresponds to the same absolute 
position on all the overlapping images. 
 
The method constructs a matrix of the linear equations and iteratively 
adjusts each of the independent image parameters until the solution 
converges below a pre-defined acceptance threshold. There are generally 
two problems that can happen with Simultaneous Solve: failure to 
converge, and excessive RMS residual error. 

 
When you accept the solution, Simultaneous Solve will: 

• Update the residual fields in the Ground Point File. 
• Update the residual fields in each of the Image Point Files. 
• Update the sensor model parameters in each of the Image Support 

Files. 
• Write a Solution Accuracy Quality Report file (with 

extension .rep) in the project directory summarizing the image 
points, residuals, and solution quality. 

• Write a second, more detailed Accuracy Summary Data report 
<atffilename>.atf.utri_rep. This contains information on QA 
statistics not available under the regular solve bundle adjustment 
method. 

 
 

1. After measuring all the needed gcp, click “Solve” in the 
“Automated Triangulation” dialog box. 
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2. A “Simultaneous Solve” dialog box will appear. Click 
“Start” . 
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3. Check if adjustment of measured gcp is finished shown at 

the bottom window. 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

 
 
 

3.1.4.2 Multi-Sensor Triangulation Residual 
 
This window displays the residuals of image coordinates of all points 
and the residuals of ground coordinates of all control points. The 
residuals are displayed in a largest to smallest order based on image 
residuals. 
 
The display residuals window provides a flexible interface to perform 
the following procedures: 

• View lists of residuals 
• Change the ground point type 
• Toggle ground points ON and OFF 
• Toggle individual image measurements ON and OFF 
• Re-measure points 
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1. Click “Residuals”  in the “Simultaneous 
Solve” dialog box. 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

2. A “Multi-Sensor Triangulation Residual” dialog box will 
appear. An RMS (Root Mean Square) below 1 is 
acceptable. If your RMS is above 1 you probably made a 
mistake in measurement. Review the residual values of 
each gcp and check the point ID which you think needs to 
be re-measured. 
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3.1.4.3 Reviewing and correcting GCP measurement with  residual 
errors. 

 
Excessive RMS residual error 
 

The RMS of all the image residuals for the block is reported once 
convergence has been achieved. The acceptability of the RMS residual 
error depends on the sensor type and GSD but should be less than 1.0 
pixel in most cases. Values greater than this indicate that one or more 
points is mismeasured and is skewing the solution excessively. 
 
The Display Residuals menu can be selected to view the current image 
and ground residuals for all the measured points sorted by magnitude. 
Unfortunately, the largest residual points may or may not be the culprit 
in skewing the solution. 
 
The first strategy should be to turn off all control points and attempt a 
relative solution first, unless the bad tie point is obvious. 
 
If you examine a point with a high residual and it looks like it was well 
measured, you can skip it and try other points until you find one that is 
mismeasured. Examine points with even numbers of image overlaps over 
2 (4, 6) and check the points between the first, third, fifth, etc. images to 
make sure that the point is measured at the same location. 
 
Also, move and remeasure points which are on rooftops or in trees. Trees 
tend to move somewhat in windy conditions, or are difficult to measure 
accurately and distort the solution when used for tie point locations. 
 
It is recommended that solutions with excessive RMS error should be 
discarded and not Saved. It is likely that the resulting math models are 
degenerate, or at least worse than the existing approximate math model. 
If the relative solution (control points OFF) shows good RMS error 
results, the math model can be Saved and the control points can be later 
remeasured. Usually the problem is not the measurement but the absolute 
ground position specified for the point. You 
should confirm from the original hardcopy control database, or other 
sources, that you have the right coordinates for the right image point, and 
that the elevation data is consistent with the project units (feet vs. meters, 
MSL vs. Ellipsoid) as specified. 
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1. After all the measured points have been calculated, using 
the “Multi-Sensor Triangulation Residual” dialog box, 
identify and select point ID’s (e.g. E006) which has a large 
Lon/X and Lat/Y value. Click right mouse button and 
select “OFF”. 
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2. In the “Automated Triangulation/Full Block” dialog box, 
click “Interactive Point Measurement”. 
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3. An “Interactive Point Measurement” will appear. Click the 
down arrow. Locate and select control points (e.g. E006) 
that were turned off. 
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4. The position of the select point ID (e.g. 538) will be 
identified on the image in view 1 and also in the gcp index 
in view 2. Set active view 1 and move cursor to a new 
position. 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

5. Check “Lock” in the “Image Points” box, select “Sample” 
and click “Save”. 

 
 
 
 
 
 
 
 
 
 
 
 
 
 

Note: Repeat steps 3 - 5 until all the control points that were 
turned off were selected, viewed and remeasured if necessary. 
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6. Click “Solve” in the “Automated Triangulation” dialog 
box.  

 
 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

7. A 
“Simultaneous Solve” dialog box will appear. Click 
“Start”. Then check the RMS if value result is less than 1.  
Then Multi-Sensor Triangulation is ok.  
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3.1.5 Product 
 

Spot image with all the measured control points  
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3.2 Creating DTM (SOCETSET) 
 
You create a DTM within the ATE or ITE applications. Depending on which 
application you are running, do the following to interactively create a new flat 
DTM: 
 
Click Extraction > Terrain > Automatic Extraction 
or 
Click Extraction > Terrain > Interactive Edit 
Click File > Create DTM... on the ATE or ITE windows. 
 
To create a DTM, you must select an ATE Method (either Adaptive ATE or 
Non-Adaptive ATE) and the images to be used when generating the DTM data 
(for explanations regarding Adaptive ATE and Non-Adaptive ATE, see 
Choosing an ATE Method section below). See “Adaptive vs. Non-Adaptive 
ATE” on page 35-1 for greater detail. If you select more than two images, the 
images must not be rectified. You must also define the boundary of the DTM. 
The DTM boundary can be: 

• A polygon 
• A minimum bounding rectangle around a polygon 
• A rectangle defined by its Lower-Left and Upper-Right corner 

coordinates 
If you are going to run ATE next, the DTM boundary should cover the 
overlapping area shared by at least two images, as shown in the figure below (for 
the case of only two images: left and 
right). 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

The DTM you create will always be rectangular. When using a polygon to define 
the DTM boundary and the polygon is not rectangular, the posts outside of the 
polygon will be marked with a Figure Of Merit (FOM) value of 
OUTSIDE_BOUNDARY and will not be considered as valid posts by any 
SOCET SET application. For TIN DTM formats, there will be no mass points 
and breaklines outside of the polygon. See the figure above for an illustration. 
 
There are four ways to define DTM boundary: 
Use Polygon  Use Minimum Bounding Rectangle around Polygon 
Use ATE Images  Specify Lower-Left and Upper-Right Corner Coordinates 
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You must also specify the new DTM’s post spacing, and a strategy or a number 
of DTM Filter parameters. You can then start Automatic Terrain Extraction to 
collect DTM data. 
 
After you create a DTM, your next step is to run one of the following 
applications: 

• ATE—For all rural imagery and for small-scale imagery of urban areas. 
After ATE, you will run Interactive Terrain Editing or DTM/Feature 
Merge. 

• ITE—For large-scale imagery of urban areas. You can use ITE to build 
the DTM manually. 

• DTM/Feature Merge—If you have a vector database containing features 
such as drains, breaklines, and ridges. 

 
 
 

3.2.1 Extract DTM Points 
 

1. Click “File” and select “Load Images”.  
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2. An “Image Loader” dialog box will appear. Create a view 
and select the required images to be used.  

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

 
 

 
 

3. The selected image (e.g. 53033190611210220512AL.sup 
and 5304320060426240041AR.sup) will be displayed in 
the view box created. 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

4. C
l
ick “Extraction”, click “Terrain”, and select “Automatic 
Extraction”.  
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5. An “Automatic Terrain Extraction” dialog box will appear. 
Click “File” and select “Create DTM”. 
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6. A “Create DTM” dialog box will appear. Select the SPOT 
images in the available box, click the arrow Click the 
browser button on the left side of the DTM box.  

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

7. A “Select a DTM” dialog box will appear. Type the DTM 
name (e.g. carto_stereo_50m). Then click “OK”.  

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

8. Select the SPOT images and click the arrow to transfer the 
images into the “Selected” box.  Then click the “DTM 
Properties” tab. 
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9. Click the “Use ATE Images” button. Type “50” in the “X 
Spacing” box and “50” in the “Y Spacing” box. Then click 
“Save”. 
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10. Click “Start”. Wait until the system process the data. 
 

 
 
 
 

11. Click “Extraction”, click “Terrain”, and select “Interactive 
Edit”.  
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12. An “Interactive Terrain Edit” dialog box will appear. Click 
the “Open DTM“ icon.  

 
 
 
 
 
 
 
 
 
 
 
 

13. A “Select a DTM” dialog box will appear. Select the dtm 
file (e.g. carto_stereo_50m_dtm). Then Click the “OK’. 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

14. Click “Setup DTM Graphis” icon in the 
“carto_stereo_50m” – Interactive Terrain Edit” dialog box. 
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15. A “Preferences” dialog box will appear. Select 
“Elevation” in the “Color Source” box. Set “20” for 
“Contour Interval”, “5” for index Interval”. Set “10” for 
“X-Steps and “10” for “Y-Steps”. Then click “OK”. 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

 
16. C

lick the “Draw Terrain Graphics” icon. 
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17. The mode (dots) selected in the “Preferences” dialog box 
will be displayed on the image. 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

 
 

3.2.2 Generate Contours 
 

1. Click “Setup DTM Graphics” icon in the 
“carto_stereo_50m” – Interactive Terrain Edit” dialog box. 
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2. A “Preferences” dialog box will appear. Select 
“Continuous” in the “Color Source” box. Set “20” for 
“Contour Interval”, “5” for index Interval”. Set “10” for 
“X-Steps and “10” for “Y-Steps”. Then click “OK”. 

 
 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

3. Click the “Draw Terrain Graphics” icon. 
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4. The mode (Editable Contour) selected in the “Preferences” 
dialog box will be displayed on the image. 
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1. Introduction 

 
VrOne is a powerful photogrammetric vector collection and editing package with image 
display capability.  Photogrammetry today requires the mapping professional to deliver 
vector, image and digital terrain model (DTM) data as digital products. VrOne addresses 
many of the problems encountered in handling the collection, editing and plotting of vector, 
image and DTM data. Map update and revision may also be done with VrOne. 

VrOne Mapping Software The NEW standard in photogrammetric mapping • Over 130 
interactive mapping applications • Over 40 batch mapping applications • Digital Terrain 
Modeling (DTM) with draping • Function Key, Macro and Python user programming • Image 
backdrop display • Stereo 3D and 3D vector viewing windows • Data translators including 
DXF, SHAPE, ASCII, CAICE, KDMS and CADMAP • Optional Microstation data 
translator • Drivers for various analytical/analog stereo plotters and xy digitizing tablets • 
Drivers for BAE Systems SOCET SET Softcopy • Image scratch and blob removal and edit • 
Hard copy plotting • Available for Windows 2000/XP VrTwo Softcopy Adds the power of 
stereo to VrOne • Real-time, seamless integration with VrOne • Interactive single model 
orientation program • Model import support in orientation program • Supports VrOne 
interactive vector data collection and edit • Static image display • Roaming image display • 
Cursor vector masking and image magnification • Single or dual screen solution • Z support 
from mouse thumbwheel or 3D mouse • StereoGraphics active or passive stereo viewing 
support • NuVision stereo viewing support • VrTwo includes VrOne (VrOne is embedded in 
VrTwo and a stand alone license of VrOne is included) VrOne, VrTwo Viewing • 
VrMapping Data viewing in stereo and mono • VrOne/VrTwo data-base compatible • View 
VrOne graphics files • View stereo models from VrTwo • Create highlight layers for later 
processing in VrOne/VrTwo • Stand-alone program Orthophoto Production made easy • 
Batch Processes large jobs • User definable orthophoto areas • Interactive single photo 
resection • Ability to import exterior orientations • Transparent DTM data import from 
VrOne • Support for TIFF (tiled/raster/jpeg) • Stand-alone program Aerial Triangulation 
Collection Innovative, familiar • Layout mode allows viewing of all photos and data • 
Interactive point measurement with auto-correlation and stereo modes • Blunder detection 
during point measurement • Flexible project management • Export to various Air 
Triangulation formats • Stand-alone program Aerial Triangulation Adjustment Adds 
adjustment to VrAirTrig • Seamless integration of collection and adjustment • One button 
strip and block adjustment • Full strip and block error reporting • Requires VrAirTrig Image 
Stitching and Balancing • Better Control of the Mosaic Process • Real-time image preview 
during seam line placement and editing • Interactive or batch sheet output • Image balancing 
between images and entire job (version 2) • User defined variable feather width per line or 
per segment • Ability to down/up sample resolution of final images • Ability to compress 
final images • Support for 8/24 bit TIFF raster or tiled images • Support for JPEG 
compression within TIFF • Flexible project and orthophoto management • Ability to output 
seams in standard DXF format • Stand-alone program Image Balancing and Tone Matching 
Make multiple images balance as one • Available inside VrMosaic or as stand-alone 
program • Fast balancing computation • Uses advanced methods to balance image color and 
intensity across all images in the project • Real-time display of global balance results before 
final images • User control over adjustment parameters • Batch adjustment of all images in a 
project Computations between Surfaces Volume computations using DTMs • Runs inside 
VrOne/VrTwo • Computes volumes between two DTM surfaces • Seamless integration • Flat 
surface DTM surface available • Requires VrOne VrOne/Microstation In/Out Translators 
Time tested translator designed by users • User friendly interface • Runs inside VrOne • 
Cross references mapping properties during translation • Uses native VrOne/Microstation 
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data-base libraries • Supports line-styles, line-patterns • Able to use client cell libraries • 
Requires VrOne  
 

2. General VrOne Configuration 

 
a) VrOne Configuration 
 
The VrOne Configuration can be accessed by either double-clicking on the Vr SOCET 
Configuration icon, or by using Windows Explorer to navigate to the \vr\bin\ directory 
and double-clicking on vrcfig_ss.exe. 
 
 
 
 
 
 
 
In the VR Configuration window: 
 
Project > Project Parameters 
Use default directories?   No 
Configuration > XYZ Digitizer 
XYZ Digitizer    BAE SYSTEMS SOCET SET 
Configuration > Keyport 
Keyport Type  Keyport 252 USB or Serial (if using a 

Keyport) None (if not using a Keyport) 
 
If the user wishes to always start with either the Mouse or XYZ Input: 

- Vr SOCET Config: General > Start input device. Select Mouse or XYZ   
Stereoplotter and press OK. 

 
But from within VrOne, either input mode can be selected by entering digmou or digxyz 
in the VrOne key-in window. 
 
If the user wants to use customized data files: 

- Vr SOCET Config > Configuration > General > Function Key File 
Enter or browse to the custom file and press OK. 
- Vr SOCET Config > Configuration > General > Keypad Command File 
Enter or browse to the custom file and press OK. 
- Vr SOCET Config > Configuration > General > Macro File 
Enter or browse to the custom file and press OK. 
- Vr SOCET Config > Configuration > Vector Graphics > Symbol File Name 
Enter or browse to the custom file and press OK. 
- Vr SOCET Config > Configuration > Vector Graphics > Pen Table File Name 
Enter or browse to the custom file and press OK. 
 

The colors used with VrOne (VrSOCET Config > Configuration > Vector Graphics > 
Use pen table?) can be defined in one of two ways: 
 
If this is set to Yes, then VrOne will use the specified pen table (which is one line above 
the “Use pen table?” line) and will map out the colors by VrOne layers. If the default 
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VrOne pen table (\vr\data\default.pen) is opened with a text editor, the Layer / Entity 
Type / Pen Number (color) is shown. Each VrOne layer (1–10001) 
can have a separate pen number for line entities, splines, symbols and text. This means 
that the colors will always be fixed based on the entity type for a specific layer. (For 
example, all lines found in layer 35 would 5 have the same color.) The default is to have 
one pen number (color) for all of the entities within a layer, but this isn’t a requirement. 
If desired, one VrOne layer could have different colors for each of the four entity types. 
 
If “Use pen table?” is set to Yes, it’s possible to cycle through the available colors with 
the following: 
 

1. Insert a line into a VrOne file. 
2. Pick the line with Pen > Change Pen. 
3. Press Button 2 to increment or Button 3 to decrement the pen number (color). 

The Change to pen number and color are shown in the main VrOne menu 
window. 

 
If “Use pen table?” is set to No, then the user will define colors to be used and won’t be 
forced to use the same color for all of the elements within a particular Layer-Entity type. 
This would then allow for the placement of utility valve, water valves, gas valves, … into 
the same VrOne layer, but each could have a different color. 
 
Lastly, VrOne doesn’t display all color combinations to the screen, but only goes up to 
pen number 70. The screen display colors are determined by \vr\data\defaultscreen.ct, 
and this file also provides a cross-reference of pen number to color name. 
 
Please refer to Appendix A – Pen Table Colors for a listing of the default screen display 
colors. 
 
b) SOCET SET Configuration 
 
Once SOCET SET is running, VrOne can be loaded by selecting the VrOne SOCET icon 
from the desktop or by selecting VrOne > VrOne SOCET from the SOCET SET 
Extraction pull down menu.  
 
The current SOCET SET versions should include VrOne SOCET and VrOne Config in 
the SOCET SET Extraction pull down menu. If VrOne is not present, it is possible to 
manually add those items to the menu as follows: 

1. Open \usr\geoset\internal_dbs\CONFIG\standard_NT.cnf with a text editor. 
2. Add the last three highlighted VrOne lines, below, to the Extraction section. 

Please note that tabs must be used to indent the lines, spaces will not be 
recognized. 

Extraction|0|0|0 
Terrain|0|0|0 

Automatic Extraction|0|2|0|$(EXEDIR)/ate PREF 
Interactive Edit|2|1|0|$(EXEDIR)/ite PREF 

Feature|0|0|0 
Feature Specification Editor|0|0|0|$(EXEDIR)/spec_ed 
Feature Extraction|2|1|0|$(EXEDIR)/fei PREF RT 
Feature Database Merge|2|1|0|$(EXEDIR)/fdbm PREF 

ClearFlite|2|1|0|$(EXEDIR)/clearflite 
Merge|0|2|0|$(EXEDIR)/dtm_ftr PREF RT 
Annotation & Counting|2|1|0|$(EXEDIR)/annot PREF 
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VrOne|0|0|0 
VrOne SOCET|0|1|0|$(VRHOME)/bin/vrone_ss 
VrOne Config|0|0|0|$(VRHOME)/bin/vrcfig_ss 
 
 

c) VrOne-SOCET Button Definitions 
 
As with other SOCET SET applications, it is possible to cross-reference the 12 VrOne 
buttons to the SOCET SET 3D input device with the following: 
 

1. Copy \vr\bin\vrone.acc to the SOCET SET events directory (e.g., 
\usr\geoset\internal_dbs\EVENTS or 
\SOCET_SET_5.3.0\internal_dbs\EVENTS). 

2. Rename…\internal_dbs\EVENTS\vrone.acc 
to…\internal_dbs\EVENTS\VRONE. 
Please note that VRONE must be upper-case. 

3. Save a copy of the current SOCET key definitions: 
copy $HOME\.socet_keys.localhost $HOME\original_keys 

4. Start up SOCET SET and activate the Keyboard/Trackball Accelerator 
Mapping window (SOCET: Preference > Keyboard/Trackball Accelerator 
Mapping). 

5. From within the Keyboard/Trackball Accelerator Mapping window, press 
the Restore All Defaults button to remove the current button definitions. 
Before doing this, please ensure that a copy of those button definitions has 
been made as suggested above. 

6. Select VrOne from the Application option menu. The events for the twelve 
VrOne buttons will appear in the list box. 

7. Select the VrOne button whose hot key you want to change in the box. Use 
the Change Mapping, Add New Mapping, or Remove Mapping buttons as 
desired. When you select Change Mapping or Add New Mapping, a dialog 
box will appear instructing you to press the key you wish to assign to the 
event. 

8. Repeat the above step for each VrOne button that you wish to cross-
reference. 

9. Click OK to save the mappings or Cancel to exit without saving. 
10. It is also possible to define unused device buttons to events in the Main 

Image Display. For example, it might be useful to assign the Zoom In and 
Zoom Out events to two unused buttons. 

11. After defining the VrOne-SOCET button events, exit SOCET SET and save 
a copy of the current VrOne-SOCET key definitions: 
copy $HOME\.socet_keys.localhost $HOME\vr_keys 

12. Then, if required, two batch files can be created with a text editor (and sent 
to the Desktop as short-cuts) to easily set the button definitions for the 
current SOCET SET session: 

 Create $HOME\vrkeys.bat (to re-initialize the VrOne SOCET button 
definitions) 

 Copy $HOME\vr_keys $HOME\.socet_keys.localhost 
 Create $HOME\socet_keys.bat (to re-initialize the original SOCET 

button definitions) 
 Copy $HOME\original_keys $HOME\.socet_keys.localhost 
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3. Starting VrOne 

With SOCET SET running (and an absolute oriented model displayed), VrOne can be started 
by either: 

- Selecting the VrOne SOCET icon from the desktop, or by 
- Selecting VrOne SOCET from the main SOCET SET menu (SOCET: Extraction > 

VrOne > VrOne SOCET). 
 

4. Exiting VrOne 

The normal procedure for exiting VrOne can be done with any of the following: 
- VrOne: File > Exit 
- Enter exi <Return> in the VrOne Key-In dialog box. 
- Clicking the Close button (X) in the upper right-hand corner of the VrOne Main 

Window. 
- Double-clicking on the VrOne icon in the upper left-hand corner of the VrOne Main 

Window. 
 

5. VrOne Help 

VrOne has extensive local Web-based Help pages that can be accessed from the About pull 
down in the VrOne Main Window. 

- VrOne: About > Help – Presents the top-level help and general usage selections. 
- VrOne: About > Global Help (key-in: ghelp) – Lists and describes the global key-ins 

that are available. 
- VrOne: About > Local Help (key-in: help) – Calls up the help section for the 

currently active VrOne command. For example, if the Reverse Line command is 
active, selecting About > Local Help or entering 
help in the Key-In dialog box will load the Reverse Line help page in your specified 
Web browser. 

 

6. Opening an Existing VrOne File  

While VrOne is running, one or more VR files can be opened with: 
1. VrOne: File > Open VR Files. 
2. Navigate to the directory containing the VR file(s) to be opened. 
3. Using the mouse to select and the arrow buttons, move the files to the Files to open 

section in the right  portion of the window 
4. Press OK in the Open VR File window 
 

7. Creating a New VrOne File  

While VrOne is running, a new VR file can be created with: 
1. VrOne: File > Open VR Files 
2. Navigate to the directory into which the new file will be created. 
3. Select the New File button in the lower-right portion of the window. 
4. Enter the New File Name, when prompted 
5. Press OK in the Open VR File window 
6. Define the VR file parameters in the Workspace window. 
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 Target Scale (1:n): whether for feet or meters, enter the ratio. For example, 1:1200 
(for 1”=100’) or 1:2000 or … 
 Units: select US Foot or Meter or International Foot 
 Coordinate Format: select State Plane or UTM 
 State plane zone 
 UTM zone 
 Description 

 

8. Closing an Existing VrOne File  

VR files can be closed with: 
1. VrOne: File > Close VR Files. 
2. Using the mouse to select and the arrow buttons, move the files to the VR Files to 

close section button in the right portion of the window. 
3. Press OK in the Close VR File window 

9. Starting an Application(Command)  

VrOne applications can be started through a number of different methods. 
- Pulling down a menu and selecting an item may start commands. 
- Commands may also be started from a key-in using the command name. Each 
command name is the first three letters of the first two words on the pull down. For 
example, the key-in command name for Insert Line is InsLin. 
- Selecting the command from a pre-programmed input device, such as a Keyport. 

10. Custom Symbol and Line Font Creation  

a) Define a New VrOne Symbol File 
 

The default symbol and line font file is \vr\data\default.sym, but it is recommended that a 
custom file with a different name (e.g., \vr\data\SomeOtherName.sym or 
D:\safe\baesystems.sym) be created to prevent the inadvertent overwriting of the file 
during VrOne upgrading. Since the default VrOne symbol file contains numerous 
examples of symbols and line fonts, it may be more practical to copy the default file to a 
new name and location and then modify that file. 
 
See Appendix B for a listing of the default VrOne line fonts and symbols. 
 
The Symbol file to be used by VrOne is specified with 
 

VR Configuration > Configuration > Vector Graphics > Symbol file name. 
 
b) Create a New Symbol or Line Font 
 
Custom symbol and line fonts are easily and quickly created with VrOne. A normal 
procedure would be as follows: 
 

1. Start with a new (empty) VrOne file or go to a blank area in an existing file. 
2. Turn the Grid Display ON (Graphics > Grid On or grion). This allows for the 

symmetrical placement of the font components. 
3. If necessary, set the Grid Display Resolution (Graphics > Set Grid Resolution or 

setgri) to a reasonable size. 



IV-4-7 

4. Draw the components that will be included in the new symbol or line font entity 
with Insert Line (Insert > Insert Line or inslin). A line font will contain the 
components needed to complete one complete unit of the font. (For example, the 
creation of a new fence line font only needs to include a single unit length of 
line with a single X.) The scale is not important, since symbols and line fonts are 
scaled at plot time. 

5. Call up the Create Symbol application (Insert > Create Symbol or cresym). 
6. Place a window box that includes the entities to be used for the new symbol or 

line font, and Accept or Reject the selection. 
7. Digitize the origin of the new symbol or line font that corresponds to the center of a 

symbol or the beginning of the line font. 
8. Specify whether it is a new symbol or line font. 
9. Enter the symbol or line font number (1-1000). 
10. Enter the symbol or line font name. 
11. Enter the symbol scale factor (usually 1.0) or the repeating line font length (which 

defines the plotting length for one line font segment when plotting the line font). 
 

c) Using a New Symbol or Line Font 
A newly created symbol or line font can be placed into the current VrOne file by 
selecting Insert Line (inslin) or Insert Symbol (inssym) and manually entering the 
number of the new symbol or line font: 
 

grp=83 (or 27 or 473) 
 

Or, as for other feature types, a function key containing the newly created symbol or line 
font number can be defined and used. 
 

1) Zoom and Window Display Functions 
Zooming into and out of the VrOne graphics window can be done from the 
VrOne menu pull-downs (Graphics > Zoom) or from key-in commands: 
  

Zoom Center   zooc         Zoom in                        zoo.5       Zoom Right       zoor 
Zoom All         zooa         2x Zoom                       zool         Zoom Down     zood 
Zoom Left       zool          Last Zoom Window     zoow        Zoom Out 2x    zoo2  
Zoom Up         zoou         Zoom Previous            zoop 

 
 

The Zoom Left/Right/Up/Down commands are also keyed to the four keyboard 
arrow keys. And the Zoom In/Out commands are keyed to the two keyboard 
Page Down/Up keys. 
 
The graphics can be replotted to all VrOne windows with 
 

Graphics > Replot rep 
 

The VrOne window rotation can be defined with 
 

Graphics > Set Window Rotation winrot 
 

This is useful if the operator wants to have the VrOne cursor move and track in 
the same direction as the SOCET SET floating mark. 
The window rotation can be set to a specific value (such as 0 or 30 or -45 degrees) 
with: 
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Environment > Set Parameters Rotation about the Z axis � 0 (or 30 or -
45) 
 

The rotz key-in command can also be used to define the window rotation angle: 
 

rotz 0 (or rotz 30 or rotz -45) 
 

Please note that the rotation defined by a rotz key-in command might also 
require that one of the above zoom commands be applied before the new rotation 
value will become apparent. 
 
The VrOne window can be configured to automatically re-center whenever the 
cursor touches the edge of the graphics window with: 
 

Graphics > Toggle Window Shift togwin 
 

Additionally, this parameter can be set globally with: 
 

Vr SOCET Config: Configuration > General Graphics > Window Shift > 
select Off or On 
 

11. Zoom and Display  

a) Displaying Line Fonts 
 
A normal behavior when VrOne entities are displayed to the screen is that lines appear to 
“lose” their fonts. This is “normal” because as the display scale gets smaller than a 
certain size, line fonts, symbols, and text will be displayed by VrOne in a simple format 
as unfonted lines (lines), single dots (symbols), and as lines (text). 
 
The solution is to zoom in and out with the Page Up or Page Down keys, or to use zoom 
window (zoow) to zoom in to a smaller area, or to manually change the display scale 
(Environment > Set Parameters > Scale (1:n): 2000). As the display scale gets larger, the 
line fonts will re-appear. 
 

VrOne Config (Global Default): Configuration > Vector Graphics > Minimum 
Text Size and Minimum Symbol Size 
 
VrOne SOCET (Session Default): Environment > Edit Configuration > 
Minimum Text Size and Minimum Symbol Size 

Also, issuing a Zoom All (zooa) command will display unfonted lines. Provided that the 
display scale is not too small, issuing a Replot (rep) command will display the line fonts. 
 
b) Display Data Disappears with ZoomAll 

 
The zooa command (Zoom All) displays and fits the entire contents of the VR file to the 
graphics screen. If there’s an outlier at say x=0 and y=0, the screen scale might be 
extremely small and no data would be visible. 
If this happens, one of the following might help: 
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1. Do a Pack VR File (File > Pack VR File) and then a Zoom All. This will 
permanently remove any deleted VR entities and will resize the XY file 
dimensions. 

2. If step 1 doesn’t work, and a small dot of data is visible on the screen, try to 
zoom into that area. If this is successful, use Insert Line and draw a box around 
the outside of the “good” area. Then use Cut Polygon (Edit > Cut Polygon or 
cutpol), set the parameters to Cut from outside and Throw data away, pick the 
newly drawn box, and accept the action. 

3. If it is not possible to see even a small dot of data, get the Range XY (File > 
Range XY or ranxy), make note of the Maximum X and Y, and then use Set 
Graphics Parameters (Environment > Set Parameters or setpar) to define the 
lower left east and north and scale to “sane” values. 
 

12. Data Collection   

VrOne has numerous routines for the interactive insertion of line, 
symbol, and  text entities. For example: Insert Line, Insert Fly 
Line, Insert Parallel Line, Insert Symbol, 
Insert Annotated Symbol, Insert Text, Insert Line Text, etc. 
These applications are typically found under the Insert pull down 
in the VrOne Main Window. 
 
When an insertion application is started, a Menu Keys dialog 
window is displayed. At the top of the window is the command 
name. The next area displays the entity parameters. This 
information is command dependent and normally shows where 
the data is to be stored on insert commands or where the data 
came from on edit commands. 
 
The third area is the menu keys area. These show what functions 
are assigned to the 12 menu key buttons. These keys are 
normally mapped onto an input device such as the keypad. They 
are also mapped onto the 12 function keys on a standard 
keyboard. 
 
Following are a few examples for inserting various types of data 
into a VrOne file. 
Specific help can be called up for each of the insertion routines 
with: 
 

VrOne: About > Local Help or key-in help 
 

For these examples: 
- Open a new VrOne file. 
- Initialize the Target Scale to 1:1200 if using English units, or 1:1500 if using 

metric units. 
- Using the Page Down and Page Up keyboard keys, set the VrOne display 

scale to approximately 1:1200 or 1:1500. 
- Use the system mouse as the input device (Input > Digitizer Mouse or 

digmou). 
 

a) Insert Line 
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The Insert Line function would be used to collect linear features where each data point is 
digitized manually, such as roads, sidewalks, fences, railroads, etc. 
 

1. Insert > Insert Line (inslin) 
2. Move the system mouse cursor into the VrOne graphics window. (While in 

this window, the cursor should change to a cross.) 
3. While moving the mouse, press and release the left mouse button (or press 

the F1 key) to digitize points. 
4. To back-up along the active line, press Button 3 (Backup) or F3. 
5. To end the line, press Button 4 (End) or F4. 
6. To end the Insert Line function, press the # Button or F12. 
7. During the insertion of a line, B2 (F2) will close, but not end, the line and B6 

(F6) will place an Arc through the last three digitized points. 
8. The mode can be changed from line mode (mod=1) to spline mode (mod=2). 
9. The line font (graphic pointer) can also be changed by entering grp=18 

(which is a treeline if using the default VrOne symbol file). 
10. The active layer can be changed by entering lay=4 

 
b) Insert Fly Line 
 
The Insert Fly Line function would be used to collect linear features where the data 
points are automatically collected in a streamline mode, such as treelines, water features, 
contours, etc 

 
1. Insert > Insert Fly Line (insfly) 
2. The Fly Line filtering parameters can be defined by pressing B7 (F7), which 

will load a Parameters window with: Tube Width, Maximum Distance, 
Dither Distance, and Z Tube Width. As described in the local help for Insert 
Fly Line, these parameters affect and determine the frequency with which 
data points are sampled and stored. 

3. Move the system mouse cursor into the VrOne graphics window. (While in 
this window, the cursor should change to a cross.) 

4. While moving the mouse, press and release the left mouse button (or press 
the F1 key) to automatically digitize points. The points will be sampled, 
filtered and stored based on the filtering parameters. 

5. To back-up along the active line, press Button 3 (Backup) or F3. 
6. To end the line, press Button 1 (End line) or F1. 
7. During the insertion of a fly line, B2 (F2) will close and end the line. Button 

4 (F4) will Force points that won’t be removed by the filtering parameters. 
B5 (F5) allows for a manually digitizing mode, and B6 (F6) lets the operator 
go back along the active line and splice in a new section. 

8. The mode can be changed from line mode (mod=1) to spline mode (mod=2). 
9. The line font (graphic pointer) can also be changed by entering grp=16 

(which is a water line if using the default VrOne symbol file). 
10. The active layer can be changed by entering lay=6  

 
c) Insert Square 
 
The Insert Square function is used to collect linear features where the internal segments 
are placed at right angles to each other. 

- Insert > Insert Square (inssqu) 
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- The squaring parameters include options to square to the Longest Side, First 
Side, Mean of All Sides and Azimuth. A Squaring Tolerance can also be 
defined that tells Insert Square to not square segments that fall outside the 
specified angle. 

 
d) Insert Symbol 
 
Symbols can be placed into the VrOne file with this function. 

- Insert > Insert Symbol (inssym) 
- Symbols can be inserted with a fixed or pre-defined radius and rotation. Or 

the size and rotation can be interactively defined as part of the digitizing 
process. 

 
e) Insert Text 
 
Text can be placed into the VrOne file with this function. 

- Insert > Insert Text (instex) 
- Text can be inserted with a fixed or pre-defined size and rotation. Or the size 

and rotation can be interactively defined as part of the digitizing process. 
- Ten different justifications can be used when placing text as well as 

numerous graphical attributes. 
 

f) Insert Annotated Symbol 
  
The Insert Annotated Symbol function is used to collect symbols with the inclusion of a 
text string, such as spot elevations, annotated fire hydrants, annotated manholes, etc. 
 

- Insert > Insert Annotated Symbol (insann) 
- The local help for this function lists the various key-ins commands that can 

be used when defining entity to be inserted. This is particularly useful when 
accessing this application from a Function Key definition. 

 
See Appendix B for examples of the different types of Annotated Symbols. 
g) Insert Line Text 
 
The Insert Line Text function is used to insert text onto an existing line. This routine 
would typically be used to place annotations on index contours. 

- Insert > Insert Annotated Symbol (inslte) 

13. Changing the Graphical Attributes 

Whenever a VrOne insertion command is started, the graphical attributes from the last usage are 
active. One of the ways in which these attributes can be changed is by manually keying in the 
new attribute(s). For example: 

 
- To change the current layer (1-10001), enter lay=4 (or lay=125 or lay=2065, etc.) 
- To change the current line mode (1-2), enter mod=1 (line) or mod=2 (spline) 
- To change the current line width (1-256), enter wid=1 (or wid=2 or wid=7, etc.) 
- To change the current graphic pointer (1-1000), enter grp=11 (or grp=24 or grp=38, 

etc.) 
- To change the current pen code (1-256), enter pen=3 (or pen=4 or pen=14, etc.) 

The better solution to the manual changing of VrOne graphical attributes is the use of pre-defined 
Function Keys, which is addressed later in this document. 
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14. Entity Search Raduis 

The VrOne entity search radius can be defined in two different ways: 
 

1. As the default (global) value from within the VR Configuration program 
VR Config: Configuration > Vector Graphics > Entity search radius (in ground units) 

2. As a session value from within the VR SOCET program: 
VrOne: Environment > Edit Configuration > Entity search radius (in ground units) 

 

15.  Data Edit 

As with the insertion applications, VrOne also has numerous edit functions. For example: Edit 
Line, Edit Symbol, Edit Text, Reverse Line, Join Lines, Square Existing, Trim Lines, Cut 
Polygon, Delete Layers, and many more. These applications are typically found under the Edit 
pull down in the VrOne Main Window. 
 

a) Edit Line 
 

- Edit > Edit Line (edilin) 
- Edit Line lets the operator move, delete, or insert new points along the selected 

line, and the line itself can be moved, copied, rotated, mirrored, or closed. 
Additionally, the graphical attributes can be modified with this routine. 
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b) Edit Symbol 
 

- Edit > Edit Symbol (edisym) 
- Edit Symbol lets the operator move, copy, delete, rotate, expand, or flip the 

selected symbol. Additionally, the graphical attributes can be modified with this 
routine. 

c) Edit Text 
 

- Edit > Edit Text (editex) 
- Edit Text lets the operator move, copy, delete, rotate, expand, change 

justification, or flip the selected text. Additionally, the graphical attributes can be 
modified with this routine. 
 

d) Trim Lines 
 

- Edit > Trim Lines (trilin) 
- Trim Lines will extend and cut-back one line to another. Options included noding, 

extension distance and polygon clearing. 
 

e) Break Line 
 

- Edit > Break Line (brelin) 
- Break Line will break a line into two entities at two user-identified points. 

 
 

f) Reverse Line 
 

- Edit > Reverse Line (revlin) 
- Reverse Line will reverse the direction of lines. At times the order of the line 

points must be in a certain direction. This is true when drawing asymmetrically-
fonted lines such as tree lines or depression contours. Reverse Line can reverse 
single lines by identifying individual lines, and it can batch reverse lines of user 
defined layers and modes. 
 

g) Join Lines 
 

- Edit > Join Lines (joilin) 
- Join Lines will join or match two lines together. The lines to be joined are 

identified by the user and may reside the same workspace or any open workspace. 
Lines that are short of each other or overlap each other may be joined. If lines are 
joined, the second line is added to the first. The line parameters of the first line 
are used when joining. Lines that are matched are graphically joined but remain 
in two entities and maintain their graphic parameters. Lines identified in multiple 
workspaces will be matched regardless of the Join Mode. 
 

h) Square Existing 
 

- Edit > Square Exist (squexi) 
- Square Existing squares existing line(s) in the current workspace or all open 

workspaces. Lines to square may be identified by pointing at them, or they may 
be squared by specifying layers in a batch mode. Line segments are rotated about 
their midpoints to the Square to Azimuth at 0, 90, 180 or 270 degrees and are re-
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intersected with the previous and next segments to square a polygon. Line 
segments that are greater than the Square to Tolerance are not squared (rotated) 
 

16. Deleting Objects 

a) Fast Delete 
 

- Edit > Fast Delete (fasdel) 
- With Fast Delete, the operator is able to delete entities by pointing at them. 
- The Search for Entity Type can include lines and/or symbols and/or text. 
- There are several procedures within VrOne that will delete entities: Edit Line, 

Edit Symbol, Edit Text, Global Change and Delete Window. But there are times 
when entities should be picked one by one for deletion. Fast Delete is a quick 
way to touch an entity and delete it. 
 

b) Delete Window 
 

- Edit > Delete Window (delwin) 
- This function will delete the contents of a user-defined window. Only those 

entities that fall completely within the window will be deleted. Entities that are 
turned off will not be considered. 
 

c) Cut Polygon 
 

- Edit > Cut Polygon (cutpol) 
- This function will cut data against a user defined polygon. Data can be cut from 

the inside or outside of the polygon, and the data can be discarded, copied to a 
file, moved to a file, or have the graphical pointer changed. 
 

17. Selecting the Active Workspace 

Up to 256 VR files can be open and displayed within VrOne, but only one file is “active” and it is 
into this file that data will be stored. The Active Workspace (VR file) can be specified with: 

- VrOne: Environment > Set Active Workspace. Enter the number of the active 
workspace (AWS) and press OK. 

- Another way to change the Active Workspace is to turn Snap On (snaon) and 
then select an entity in one of the non-active workspaces. The Snap window 
appears and, by pressing button #7 (Change to Ws x), the user will be able to 
select the AWS in which the snapped-to object was found. 

 

18. Batch Editing 

VrOne also has numerous batch edit functions. For example: Batch Attach Line, Batch Join Lines, 
Batch Node Lines, Batch Offset, Batch Trim, Line Cross, Line Close, Global Change, and many 
more. These applications are typically found under the Batch pull down in the VrOne Main 
Window. 
 

a) Batch Join Lines 
 

- Batch > Batch Join Lines (batjoi) 
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- This batch routine will attempt to join lines within the layers specified. If more 
that one workspace is open and Workspaces to consider is set to All open then 
lines between workspaces will be matched. Data layers, line modes, and graphic 
pointers can also be considered. Care should be taken when setting the Search 
Distance. Undesirable joins may occur if this parameter is too large. Layers that 
are turned off will not be considered when searching. 
 
 

b) Batch Trim 
 

- Batch > Batch Trim (battri) 
- This batch routine will make up to 60 different trimming passes on the specified 

VrOne workspaces and will extend and cut-back one set of lines to another, 
change graphics pointers, and will delete or relayer the trimmed segments. 
 

c) Batch Node Lines 
 

- Batch > Batch Node Lines (batnod) 
- This batch routine will make up to 60 different noding passes on the specified 

VrOne workspaces.Options include the ability to node lines only (which places a 
common point on each line at the intersection) or node and break lines at the 
intersection points. Under-shoots and over-shoots will be considered. 

- The Z rule for computing the elevation at the intersection of the two lines can be 
specified. During noding, an elevation for each line is computed at the break 
point. These elevations are based on the slope of the line segment as determined 
by the point before and after the break point. The Z Rule determines the action to 
be taken on these two elevations as follows: 

 Original elevations – The elevations of the break points is not modified 
 Mean node elevations – The elevations are averaged and stored for both 

node points. 
 Elevation from line 1 – The elevation from the node point on line 1 is used 

on both lines. 
 Elevation from line 2 – The elevation from the node point on line 2 is used 

on both lines. 
 

d) Batch Filter Lines 
 

- Batch > Batch Filter Lines (batfil) 
- This batch routine will searches for lines within the specified layers and will 

reduce the amount of points on those lines with a tube width and maximum 
distance filter. Layers that are turned off will not be considered when searching. 
 

e) Batch Offset 
 

- Batch > Batch Offset (batoff) 
- This batch routine will searches for lines found within the specified layers and 

will place up to 10 additional lines that are parallel to the original. Each new line 
can have a layer width, graphic point, horizontal offset and vertical offset that are 
different from the source line. 
 

e) Line Close 
 

- Batch > Line Close (linclo) 
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- This batch routine will close or will check for closure of lines in user defined 
layers. Lines that are not closed may be closed by one of the following methods: 

 Move the endpoint onto start point 
 Mean the endpoints 
 Add line segment between the endpoint and the start point 
 Intersect the end segments 
 Report unclosed polygons in drive file only (do not modify line) 

- A drive file is always created for unclosed lines even if this application closes 
them. 
 

19. Global Change 

- Batch > Global Change (glob) 
- This extremely powerful batch routine will make up to 60 passes on the specified 

VrOne workspaces and will globally change line, symbol and text attribute 
information. Each pass has Search For and Change To criteria. 

 

20. Undo Last 

- File > Undo Last (undo) 
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21. Function Keys 

The use of Function Keys provides one of the most important aspects of VrOne custom data 
collection. Taking the time to properly set up function keys before starting a project has the 
potential to save hundreds of hours of production time. 
 
Function keys reduce the amount of knowledge the mapping professional needs to know about 
VrOne. They simply choose the feature they want to collect and go. Entering its name or function 
key number may start a function key. These names or numbers may be keyed in, placed in 
macros or even placed in other function keys. 
 
For example, if the operator wanted to collect an asphalt road, the Insert Line command would be 
started, and the various attributes specific to that feature would need to be defined, such as Layer, 
Mode, Line Width, Line Font, and Pen Code. But VrOne function keys would allow for the pre-
defining of this feature, so that the operator would simply enter a numeric code or a descriptive 
term for the asphalt road, which would automatically assign all of the desired parameters and 
behavior to Insert Line and start the command. 
 
 
 
A more detailed description of VrOne Function Keys can be found at 
 

VrOne: About > Help > Getting Started with VrOne > Function Keys. 
 

The default function key file is \vr\data\default.fk, but it is recommended that a custom file with a 
different name (e.g., \vr\data\SomeOtherName.fk or D:\safe\socet.fk) be created to prevent the 
inadvertent overwriting of this file during VrOne upgrading. The Function Key file to be used by 
VrOne is specified with 
 

VR Configuration: Configuration > General > Function key file 
 
 

22. Touch Pad and Key-in Input 

Just as the use of VrOne Function Keys facilitates the collection of specific project-related 
features by automatically assigning the desired parameters and behavior to one of the Insert 
commands, incorporating a touch pad input device with a feature extraction system adds even 
more efficiency to the collection capabilities. 
 
The Keyport 252 is a touch-sensitive programmable keypad that can be used with VrOne. The 
252 programmable keys can have the standard VrOne commands and VrOne Function Keys 
assigned to individual keys, which allows an operator to press a single key to activate a particular 
feature to be collected. 
 
The default keypad file is \vr\data\default.kp, but it is recommended that a custom file with a 
different name (e.g., \vr\data\SomeOtherName.kp or D:\safe\socet.kp) be created to prevent the 
inadvertent overwriting of this file during VrOne upgrading. The Keypad file to be used by 
VrOne is specified with: 
 

VR Configuration: Configuration > General > Keypad command file 
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The syntax of the keypad file (default.kp or socet.kp) is: 
 

@xxx VrOne_KeyIn_Command 
 

where xxx is the Keypad Number defined for a particular key (see “kpvr252_numbers.doc” for 
the key numbering reference) and VrOne_KeyIn_Command is the key-in command, FKey 
Name or FKey Number that 
VrOne recognizes for its various applications. 
 
For example: inslin (for Insert Line), instex (for Insert Text), rep (for Replot), zooa (for Zoom 
All), zoow (for Zoom window), exi (for Exit), bldg (for FKey Building). 
 

23. Macros 

 
Macros give the ability to execute a group of VrOne commands as a single word. Macros can 
execute VrOne commands, function keys and other macros. One common use of macros is to 
have it set specific snap parameters for a certain situation. Also, with 10,001 layers that are 
available with VrOne, a macro can also be created to easily turn groups of layers on and off. 
 

24. Application Overlay 

 
Application Overlaying lets the operator place the current command into a “pause” mode while 
other commands are executed. 
 
Multiple applications may be overlaid and stacked within VrOne which allows the operator to 
collect data in the order it presents itself instead of feature type by feature type. This unique 
VrOne feature allows for the collection of data in a flexible and realistic way. 
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Appendix A – Pen Table Colors 

VrOne Pen Table Colors 
Filename: \vr\data\defaultscreen.ct 
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Appendix B 

Default Line Fonts and Symbols (socet.sym) 
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Appendix C – Types of Annotated Symbols 

Spot with Fixed Position Text 
 

 
 
 
 
 
 
 
 
 
 
 



IV-4-23 

Spot Elevation with Manually Placed Text (freely positioned by 
the operator) 
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Spot Elevation where the Decimal Point Indicates the 
Location 
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Manhole with an “MH” String 
Manhole: Symbol definition 
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Manhole: Text definition 
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Fixed Text String 
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Appendix D – Key-In Cross Reference 
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