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1. Introduction  
This module is an advanced raster to vector from image sources, such as scanned 
maps and drawings. The system combines the power of intelligent automatic 
digitizing technology with an easy-to-use and understands.  

With this module of conversion, you can forget about slow and inaccurate hand 
tracing on a digitizing tablet, simply scan your map apply the module, you can get 
the result automatically, at a high accuracy level.  

2. Software used 
Image processing:   Adobe Photoshop 

Raster to vector conversion:  R2V 

GIS software:   ArcInfo and ArcView 

3. Methodology Flow chart 
Click here to see the flow chart. 

4. Scanning hard copy map 
Scanning is a computer related process for conversion analog data (hard copy of 
any spatial data) to digital form (the form that can be displayed, edited and 
manipulated by computer).  

For accuracy and ease in the onscreen digitization process the scanned image 
needs to have some characteristics according to level of preciseness you want to 
achieve such as resolution, color deep, band mode and format. 

In this methodology, the used characteristics are indicated as below: 

Resolution = 300 dpi • 
• 
• 
• 

Color deep = 8 bits 
Band mode = RGB 
Format = *.tif 

  
5. Working with Photo-editor environment (Photoshop software) 
In this tutorial, we will use only a portion of the scanned image in order to reduce 
the processing time. The selected portion of the image needs to include ground 
control points GCP at least four at the corners of that image. Click here to see the 
portion of the image and its associated GCP points. 

Below is the coordinate system of the GCPs in UTM and Indian 60 datum. 
Table 5-1 Coordinate System of Ground Control Points (GCP) 

ID X_coord Y_coord 
1 737270 1559840 
2 733350 1559840 
3 733350 1556970 
4 737270 1556970 

 
In order to make it easy for the vector abstraction from the scanned image, we 
have to separate the original image into layers according to the thematic layers 
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included in the original image. In this case we will separate the original image 
(click here to see the picture) into two layers according to its color the black color 
and the red color representing landuse and river respectively. 

 
5.1. Separate the image into Black layer 
To do this: 

1. Open the original image in Photoshop environment, if you have not 
done so, 

2. Choose the “Magic Wand Tool” and click once on the black part of the 
image, you can see some black part of the image will be selected, 

3. From Select menu, choose Similar, to select all of the black part of the 
image, 

4. From Select menu, choose Inverse, to select the unwanted part of the 
image, 

5. From Edit menu, choose Clear, to delete the unwanted part from the 
image, 

6. From File menu, choose Save As, to save the layer, save it in image 
folder, Layer1 as the file name and *.tif as file format. Except IBM PC 
option. To see the back layer, click here!                      

 
 To see the Demo, click here! 

 
5.2. Separate the image into Red layer 
This step is a bit more complicated than the first time because the four GCP points 
(in black color) need also to be included in the red layer. Meaning that we have to 
select two different colors for a layer. 

 
To do this: 

1. Open the original image in Photoshop environment, if you have not 
done so, 

2. Choose the “Magic Wand Tool” and click once on the red part of the 
image, you can see some red part of the image will be selected, 

3. From Select menu, choose Similar, to select all of the black part of the 
image 

4. Use Zoom tool to zoon in one corner that we can see a GCP clearly, 
5. Press on Shift key and use Magic Wand Tool to select the GCP included 

into our selection, 
6. Do the same way to select the other three GCP points 
7. From Select menu, choose Inverse, to select the unwanted part of the 

image, 
8. From Edit menu, choose Clear, to delete the unwanted part from the 

image, 
9. From File menu, choose Save As, to save the layer, save it in image 

folder, Layer2 as the file name and *.tif as file format. Except IBM PC 
option. 

To see the red layer, click here!                                           
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To see the Demo, click here! 

 
6. Working with Automatic digitizing software (R2V) 
R2V provides an easy and complete solution to digitize vector data from image 
sources, such as scanned maps and drawings, aerial photos and satellite imagery. 
The entire raster to vector conversion process is fully automatic and needs no 
human intervention. You display the scanned image on screen and you select the 
vectorization command. That is all it takes! All the lines are extracted in seconds 
and displayed right on top of the image for you to verify and edit. Powerful editing 
and processing functions are provided to edit, geo-reference and label your data. 
R2V has all the tools to get a perfect set of vector data faster and easier than any 
other methods. 

For the hold process, only layer1 will be used for demonstration. You can try by 
yourself for layer2 (red color). 

6.1. Automatic vectorization 
This command performs the automatic vector extraction or vectorization algorithm 
to detect all the lines from the image and display the vector data on top of the 
image for verification and editing. All vectorized lines are stored in the current 
layer. 

With this command, we will vectorize our layers, black and red layers. Then 
export the vector data into GIS environment for further processing. 

To do this: 
1. Run R2V software, 
2. Open the black layer (layer1.tif), the image displayed in the R2V 

desktop screen, 
3. From Image menu, choose conversion, then 24-bit RGB to GrayScale, 

to convert the image into gray scale mode, 
4. Click once on Auto Vectorize tool. When the vectorization parameter 

dialog box appears, select the Center Line: Extract lines by tracing the 
center of all line features, 

5. Click Start button to get the vector result. 
6. From File menu, choose Save Project as…, the save as dialog box 

appeared, 
7. Save the file in the image directory and give “project1” as the file name, 
8. Click Save button. Below is the result of vectorization. 
9.  

To see Layer 1 and its Associated Vector Line, click here. 

To see the Demo, click here! 

As you can see from this picture, the vector lines just created are not smoothed 
enough. The next step will use the command in R2V to smooth the lines. 

6.2. Smoothing the created vector lines 
This command does a global nodes thinning using a user specified threshold. The 
threshold is a distance in pixel between a node and its line. When the distance 
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between a node and its line is less than the threshold, the node is removed from the 
line. If the threshold is set as 0, then only these duplicate or redundant nodes are 
removed, no further smoothing is performed. 

When a selection rectangle is set in the image, you will have the option of 
applying this operation to the selected region only. 

When the dialog box appears, the default value for the threshold is 1. If this is the 
first time, click “Apply” button to try it. Smoothed lines are displayed on screen 
when the processing is done. If more thinning is desired, enter a larger value and 
then click “Apply” button. Increment of 1 to the threshold can cause a significant 
thinning to the vector data. Be careful not to use too big of a threshold to avoid 
over thinning. When the thinning is done, select “OK” to confirm it. If you want to 
recover your original data without the thinning, select “Cancel”. 

In this case we will smooth the vector lines that has just been created. 

To do this: 
1. With the project still open,  
2. From Vector menu choose Smooth lines, the Smooth Line dialog box 

appears, 
3. Keep the threshold value = 2 and click OK button, 
4. The lines are smooth, look like the one in picture below. To see the 

smoothed vector lines, click here! 
 

To see Demo, click here!                                 

 
6.3. Editing and cleaning vector line 
With the line editor, you can add new lines, add a node, move a node, delete a 
node, delete a line and delete all lines. When the tool is started, the cursor will 
change according to the editing mode. Use right mouse button to get the editing 
pop up menu or the tool bars for editing options. An option is checked if the 
corresponding editing mode is currently active. 

As you can see from the picture below, even though the lines were smoothed there 
are some error line created along with the process of automatic vectorization as 
indicated by circle numbered 1 (short lines) and circle numbered 2 (longer lines). 
To correct those mistakes two methods will be used: automatic (for the short lines) 
and manual (for the long lines) corrections. To see the picture of Vector Line 
Before Editing, click here! 

(1) Automatic Editing 
To do this: 

1. With the project still open, zoom into the place where there arc error 
lines exist to have a closer look, 

2. From the Vector menu, click on Delete Line by Length…, the Remove 
Lines dialog box appears, 

4     Prepared by JICA Study Team 



Raster to Vector Conversion Manual 

3. Under Enter Threshold option, type 5 for the max value, then click 
Apply button, if the lines are not remove keep increasing the value until 
the sort lines will be deleted automatically, 

4. Then Click OK to accept the result. 
 

To see the picture showing the mistake lines in the circle numbered 1 now have 
been removed, click here. 

To see the Demo, click here! 

(2) Manual Editing 
1. With the project still open, zoom into the place of circle numbered 2 to 

have a closer look, 
2. Click on Line Editor button to activate its associated buttons, 
3. Click on the Delete Line tool, then click once on the error line to delete 

its, 
4. Keep doing the same way until all of the error lines will be remove.  

 

To see the picture showing the mistake lines in the circle numbered 2 now have 
been removed, click here.  

To see the Demo, click here! 

6.4. Exporting the vector lines 
Now our vector layer is ready to be exported into a format that can be read by 
ArcInfo software. Later, we will export the layer as *.arc format. The exported 
data need to have the information about its coordinate system in order to be used 
with others GIS data. So the 4 control points need to be remained with the data for 
the hold process.  

 
To do this: 

1. With the R2V project file still open, from File Menu choose Export 
Vector. The save as dialog box appeared. 

2. From the save as box, select the Ras2Vec directory from the save-in 
option. Type “Myvector1” as file name and choose *.arc as file type. 
Then click Save button. Click here to see the demo. 

 
7. Working with GIS software 
This is the time to get into GIS software environment. Remember that we have just 
created a file “Myvector1.arc” stored in Ras2Vec directory. We will walk across 
two sections: ArcInfo and ArcView. 

In ArcInfo environment, the following task will be performed: 

1. Convert myvector1.arc file into ArcInfo Coverage, 
2. Creating an empty coverage with real world coordinate system 
3. Editing tic locations 
4. Transform the coverage into its real world coordinate system, 
5. Cleaning, building topology and editing the coverage, 
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In ArcView environment, the coverage will be displayed by the landuse code and 
associated with its image files. 

 
7.1. In ArcInfo Environment 
(1) Converting Myvector1.arc into ArcInfo Coverage 
We will use ArcInfo command “Generate” to convert Myvector1.arc into ArcInfo 
coverage named “Myvector”. 

 
To do this: 

1. Get into Ras2Vec workspace by typing “w ras2vec” from Arc prompt: 
“Arc: w ras2vec”, 

2. To make sure that the file exists in the workspace, use the command: 
“Arc: &sys dir *.arc”. The file will appear if the file was successfully 
exported from R2V environment. 

3. Use the command Generate, subcommand Input and line as below: 
 
Arc: generate myvector <enter> 
Generate: input myvector1.arc <enter> 
Generate: line <enter> 
Generate: q <enter> 
Arc: lc <enter> 

 

After the last command entered, ArcInfo will list the coverage named “Myvector” 
indicating that the coverage was successfully created. To see demo click here! 

(2) To create empty coverage 
To do this: 

1. Start ArcInfo and go to the Ras2Vec workspace if you have not done so, 
2. Then create an empty coverage “MYVECTORT” by using the following 

commands: 
 

Arc: create myvectort <enter> 
Creating coverage myvectort 

Arc: lc <enter> 
 Workspace:        C:\RAS2VEC 
 Available Coverages 
 ------------------- 
  MYVECTOR          MYVECTORT 

Arc: tables <enter> 
Copyright (C) 1982-1998 Environmental Systems Research Institute, I 
All rights reserved. 
TABLES Version 7.2.1  (Thu Apr  2 15:59:38 PST 1998) 

Enter Command: sel myvectort.tic <enter> 
0 Records Selected. 

Enter Command: add <enter> 
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              1 
IDTIC: 1 
XTIC: 737270 
YTIC: 1559840 
              2 
IDTIC: 2 
XTIC: 733350 
YTIC: 1559840 
              3 
IDTIC: 3 
XTIC: 733350 
YTIC: 1556970 
              4 
IDTIC: 4 
XTIC: 737270 
YTIC: 1556970 
              5 
IDTIC: <enter> 

 
Enter Command: list <enter> 
Record  IDTIC         XTIC         YTIC 
     1      1   737270.000  1559840.000 
     2      2   733350.000  1559840.000 
     3      3   733350.000  1556970.000 
     4      4   737270.000  1556970.000 

Enter Command: q <enter>; to return to Arc prompt. 

To see demo click here! 

 
(3)  Editing Tic locations 
To do this: 

1. Get into ArcEdit environment:  
• Arc: arcedit <enter> 
• Arcedit: Display 9999 <enter> 

2. Draw the imported coverage “Myvector”: 
• Arcedit: mape myvector <enter> 
• Arcedit: edit myvector <enter> 
• Arcedit: Drawe arc tic <enter> 
• Arcedit: Draw <enter>, the coverage displayed on the Arcedit 

screen, 
3. Move tics from their current location to the actual locations: 

• Arcedit: ef tic <enter>, to specify that the tic features will be 
edited, 

• From Arcedit menu Pan/Zoon, choose extent, and then use the 
cursor to zoom in on a tic that it can be seen clearly. 

• Arcedit: select <enter>, use the cursor to select a tic, 
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• Arcedit: Move <enter>, to move the tic, 
4. Repeat to do the same way until all of the tics will be moved into their 

actual location. 
5. Save the work: 

Arcedit: Save <enter> • 
To see demo, click here! 

 
(4) Transform the coverage into its real world coordinate system 
Our coverage that has just created does not have geo-reference information. With 
this process the coverage will be transformed into its real world coordinate system.  

 
To do this: 

Use the command Transform from Arc promp: 

  Arc: Transform <enter>, to see its usage, 
Usage: TRANSFORM <in_cover> <out_cover> {AFFINE | PROJECTIVE | 
SIMILARITY} 

Where <in_cover> is “Myvector”and <out_cover> is “Myvectort”. We 
will use projective option. 
Arc:transform myvector myvectort projective<enter>, after the process 

finished the following message appears to show the accuracy of the transformed 
product. 
 

Approximate scale = 5.117 
RMS Error (input,output) = (0.000,0.000) 
2D Projective  X = (Ax + By + C) / (Gx + Hy + 1) 

            Y = (Dx + Ey + F) / (Gx + Hy + 1) 
  A =            5.164   B =           -0.062   C =       733309.058 
  D =            0.099   E =           -5.247   F =      1559901.392 
  G =            0.000   H =            0.000 
 
tic id         input  x         input  y 
               output x         output y          x error          y error 
------ ---------------- ---------------- ---------------- ---------------- 
     2            8.000           12.000 
             733350.000      1559840.000            0.000            0.000 
     1          774.002           11.960 
             737270.000      1559840.000            0.000            0.000 
     4          773.967          572.988 
             737270.000      1556970.000            0.000            0.000 
     3            8.001          573.002 
             733350.000      1556970.000            0.000            0.000 
 

To see the demo, click here! 
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(5) Cleaning, building topology and editing the coverage 
The coverage now has geo-referent information. However before it can be used as 
a GIS database, the coverage need to be cleaned, built topology and edited. 

 
1) Cleaning 

 
To do this: 
Use command CLEAN from Arc prompt: 

Arc: clean <enter>, to see its usage, 
Usage: CLEAN <in_cover> {out_cover} {dangle_length} {fuzzy_tolerance} 
             {POLY | LINE} 
 Where <in_cover> is Myvectort, {out_cover} is Myvectorc, Dagle_length = 10 
and Fuzzy_tolerance = 0.1 
 
  Arc: clean myvectort myvectorc 10 0.1 <enter>, after the process 
finished the coverage will be cleaned. 
 
To see Demo, click here! 

 
2) Building topology 

To do this:  
Use command BUILD from Arc prompt: 

Arc: Build <enter>, to see its usage, 
Usage: BUILD <cover> {POLY | LINE | POINT | NODE | ANNO.<subclass>} 
 Where <cover> is myvectorc and poly option will be used, 
 

Arc:build myvectorc poly <enter>, after the process finished the topology 
of the coverage will be created. 

 
To see Demo, click here! 

 
3) Editing 

This is the time where we can add and delete lines; edit dangle and rebuilding 
topology for the coverage. 

 
To do this: 

1. Get into Arcedit environment and display the coverage setting features to 
be drawn as arc node dangle, 

2. Chang the color of dangle node to be red: 
Arcedit:  nodecolor dangle 2 <enter> 
Arcedit: draw <enter> 
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3. Deleting non-necessary arcs, 
Arcedit: ef arc <enter> 

46 element(s) for edit feature ARC 
Coverage has no COGO attributes 

Arcedit: sel box;delete <enter>, open a box around the arc to 
delete, 
Define the box 
4 element(s) now selected 
4 arc(s) deleted, the 4 arcs now deleted, repeat to do the same way until all 
of non-necessary arcs will be deleted. 

 
4. Adding boundary to the coverage, 

Arcedit: add <enter>, use the following menu to add arcs to the 
coverage: 

 
--------------------Options-------------------- 
 1) Vertex              2) Node                3) Curve 
 4) Delete vertex       5) Delete arc          6) Spline on/off 
 7) Square on/off       8) Digitizing Options 9) Quit 
(Line) User-ID: 1 Points     5 
(Line) User-ID: 2 Points ----- 
1 arc(s) added to C:\RAS2VEC\MYVECTORC 

 
5. Cleaning the coverage, 

Arcedit: clean <enter>, 
 

6. Editing dangle errors by deleting overshoot arc, 
Arcedit: sel box;delete <enter> 

Define the box 
1 element(s) now selected 
1 arc(s) deleted, 

 
7. Repeat to do the same way until the overshoot arcs will be deleted, 
8. Saving the changes, 

Arcedit: save <enter> 
 

To see Demo, click here! 

 
7.2. ArcView Environment 
In ArcView environment, the following tasks will be performed: 

1. Overlaying the coverage with its original image, 
2. Assigning landuse code to the coverage, 
3. Display the coverage by landuse code characteristics. 

 
(1) Overlaying the coverage with its original image, 
To do this: 
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1. Start ArcView 3.2 program, 
2. Add Geo-referent image as a theme into a view, 
3. Add the vector coverage “Myvectorc” as poly and arc into the same 

view. 
To see Demo, click here! 

  
(2) Assigning landuse code to the coverage, 

1) Adding “Class” field into theme attribute table 
To do this: 

1. Click on the polygon theme of Myvectorc coverage to make it active, 
2. Click once on “Open Theme Table” button, the table displays 
3. In table menu, from Table menu, choose Start Editing, the table 

changes into editing mode, 
4. From Edit menu, choose Add Field, a Field Definition box appears 
5. Type “Class” for the field name, accepts type as String, Width sets to 3, 

click OK. 
6. From Table menu, choose Stop Editing; accept the changes to be 

applied to the table. 
To see Demo, click here! 

 
2) Assigning landuse attribute to the polygon coverage 

To do this: 
1. Make the vector polygon theme active and visible, 
2. Make sure that the attribute table is in editing mode, 
3. From the view panel, use Select Feature tool to select a polygon (The 

biggest in the middle) its attribute can be seen for original image or hard 
copy paper, then its record in the table is also selected, 

4. From table panel, use the Edit tool to add “As” as Class attribute in the 
selected record, 

5. Repeat to do that until all of the polygons will has their class attributes, 
 

To see Demo, click here!  

(3) Display the coverage by landuse code characteristics 
To do this: 

1. Double click on the polygon theme “Myvectorc” to bring its legend tool 
box, 

2. From the box, choose Unique Value for Legend Type and Class field 
for Values Field, all of the class attribute now displays in the Legend 
Editor box, 

3. Click Apply button to apply those color arrangement to the polygon 
theme. 

 
To see Demo, Click here! 
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8. Exercise 
Remember we still have one more raster layer “Layer2.tif” stored in 
C:\RAS2VEC\IMAGE folder. 
 
Now your task is to convert a polygon vector coverage from that image 
using all software (Photoshop, R2V, ArcInfo and ArcView) and all 
method. 
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Figure 8-1 Methodology Flow Chart 

 
Go back 
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Figure 8-2 Scanned Original Image and Its GCPs 

 
Go Back 

 
 
 

Figure 8-3 The Separated Black Layer 

 
Go Back 
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Figure 8-4 The separated Red Layer 

 
Go Back 

 
 
 

Figure 8-5 Layer 1 and its Associated Vector Line (Green color on top) 

 
Go back 
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Figure 8-6 Layer 1 and its Associated Vector Line Smoothed 

 
Go back 

 
 
 

Figure 8-7 Vector Line Before Editing 

 
Go back 
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Figure 8-8 The mistake lines in the circle numbered 1 now have been removed 

 
Go back 

 
 
 

Figure 8-9 The mistake lines in the circle numbered 2 now have been removed 

 
Go back 

 
 
 
 
 
 

Prepared by JICA Study Team     17 



Raster to Vector Conversion Manual 
 

Figure 8-10 The Cleaned Vector Layer 

 
Go back 

 
Figure 8-11 Magic Wand Tool 

 
Go back 

 
Figure 8-12 Line Editor 

 
Go back 
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